maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben Anderson <benanderson...@gmail.com>
Subject Re: maven test:test
Date Wed, 03 Nov 2004 12:35:34 GMT
That did it - I didn't have <unitTestSourceDirectory> defined - I was
just going off of this:
http://maven.apache.org/reference/user-guide.html#POM_Inheritance

Once again I will say that it'd be pretty much impossible to use maven
w/out being on this list or else delving into the code for every
little thing as the documentation is so poor.  But I'm not complaining
because this list has been very good to me :-)

Thanks,
Ben


On Wed, 3 Nov 2004 05:30:09 -0700, Charles Daniels <cjd4@yahoo.com> wrote:
> Try adding these within <build>:
> 
> <sourceDirectory>${maven.src.dir}</sourceDirectory>
> <unitTestSourceDirectory>${maven.src.dir}</unitTestSourceDirectory>
> 
> Notice that /com is not specified.
> 
> 
> 
> > -----Original Message-----
> > From: Ben Anderson [mailto:benanderson.us@gmail.com]
> > Sent: Wednesday, November 03, 2004 5:24 AM
> > To: users@maven.apache.org
> > Subject: maven test:test
> >
> > Hi,
> > I have this in my project.xml
> >   <build>
> >     <sourceDirectory>${maven.src.dir}/com</sourceDirectory>
> >     <resources>
> >       <resource>
> >         <directory>${maven.src.dir}</directory>
> >         <includes>
> >           <include>*.xml</include>
> >           <include>*.dtd</include>
> >         </includes>
> >       </resource>
> >     </resources>
> >     <unitTest>
> >       <includes>
> >         <include>${maven.src.dir}/**/*Test*.java</include>
> >       </includes>
> >       <excludes>
> >         <exclude>${maven.src.dir}/**/TestAll.java</exclude>
> >         <exclude>${maven.src.dir}/**/*Abstract*.java</exclude>
> >       </excludes>
> >     </unitTest>
> >   </build>
> >
> > my maven.src.dir I define elsewhere, but that's beside the point.  I
> > have a Test file right along side the rest of my src code.  When I do
> > java:compile, it gets compiled.  But when I do test:test I get "no
> > tests to run".  I tried taking out the ${maven.src.dir} inside the
> > <unitTest> tags, but that didn't help.  Any ideas what I'm doing
> > wrong?
> > Thanks,
> > Ben
> > 
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> > For additional commands, e-mail: users-help@maven.apache.org
> >
> 
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message