maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Janos Mucsi <muc...@yahoo.com>
Subject XDoclet in Maven - almost good
Date Tue, 16 Nov 2004 03:35:17 GMT
I cleaned out the cache so everything was downloaded
very well, I am still getting the following error:

C:\temp\eclipse\PlutoApp\modules\everest-module-registration>maven
ejb:install
 __  __
|  \/  |__ _Apache__ ___
| |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
|_|  |_\__,_|\_/\___|_||_|  v. 1.0.1

Attempting to download xdoclet-ejb-module-1.2.2.jar.
206K downloaded
Attempting to download xdoclet-1.2.2.jar.
143K downloaded
Attempting to download xjavadoc-1.0.3.jar.
229K downloaded
Attempting to download
xdoclet-hibernate-module-1.2.2.jar.
46K downloaded
Attempting to download xdoclet-jboss-module-1.2.jar.
84K downloaded
Tag library requested that is not present: 'doc' in
plugin: 'maven-ejb-plugin-1.
5'
build:start:

ejb:init:
java:prepare-filesystem:

java:compile:
    [echo] Generates EJB classes and descriptor files

BUILD FAILED
File......
C:\temp\eclipse\PlutoApp\modules\everest-module-registration\maven.xm
l
Element... attainGoal
Line...... 8
Column.... 51
No goal [xdoclet:ejbdoclet]

In maven.xml I have:

<preGoal name="java:compile">
        <echo>Generates EJB classes and descriptor
files</echo>
            <attainGoal name="xdoclet:ejbdoclet"/>
    </preGoal>


In project.xml how many dependencies must I declare?
>From the previous postings I gathered that one is
enough?
I currently have these:

<dependency>
            <groupId>xdoclet</groupId>
           
<artifactId>xdoclet-ejb-module</artifactId>
            <version>1.2.2</version>
            <type>jar</type>
            <properties>
               
<eclipse.dependency>false</eclipse.dependency>
            </properties>
      </dependency>
       <dependency>
            <groupId>xdoclet</groupId>
            <artifactId>xdoclet</artifactId>
            <version>1.2.2</version>
            <properties/>
        </dependency>
        <dependency>
            <groupId>xdoclet</groupId>
            <artifactId>xjavadoc</artifactId>
            <version>1.0.3</version>
            <properties/>
        </dependency>
       <dependency>
            <groupId>xdoclet</groupId>
           
<artifactId>xdoclet-hibernate-module</artifactId>
            <version>1.2.2</version>
            <properties/>
        </dependency>
        <dependency>
            <groupId>xdoclet</groupId>
           
<artifactId>xdoclet-jboss-module</artifactId>
            <version>1.2</version>
            <properties/>
        </dependency>


Thanks!
Janos


		
__________________________________ 
Do you Yahoo!? 
The all-new My Yahoo! - Get yours free! 
http://my.yahoo.com 
 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message