maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Arnaud HERITIER <aherit...@gmail.com>
Subject Re: Compatibility with Ant 1.6?
Date Thu, 14 Oct 2004 15:53:10 GMT
I'm aggree with you. The ant limitation is annoying but there are
actually two problems :
- An annoying incompatible change in Ant between the 1.5.X and the
1.6.X complicates the ant upgrade in the maven's core. It's a question
of time. As soon as one of us will have the time to fix it, it will be
done. We hope that future ant releases won't break our integration.
- There's a big problem in maven 1 because there's not a separate
classloader for the core and for plugins. We are not able to use one
release of ant in the core and another in a plugin. I think that this
issue will be addressed in maven 2.

In the meantime, we are forced to do with these issues.

If you are interested to help us, you can try to submit patches !!

That were my 2 cents :-)

Arnaud

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message