maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bain, Sinclair" <sinclair.b...@PANACYA.com>
Subject Runtime Dependencies Question
Date Mon, 23 Aug 2004 18:36:03 GMT
Hi 
Our project has a runtime(/test-time) dependency upon 
the <xerces-2.6.1.jar>. However when executing 
'maven test:test' the 2.6.1 version is not used. It 
appears that the <xerces-2.4.0.jar> from the 
'(%MAVEN_HOME%)/lib/endorsed' is used by maven.

Ant has the 'boolean' <includeAntRuntime> property 
however I have been unable to identify an equivalent in
maven.

How can I encourage my test cases to use the xerces 2.6.1 version 
which is in the local repository and specified in the project.xml as
follows:

	...
    <dependencies>
        <dependency>
            <groupId>xerces</groupId>
            <artifactId>xerces</artifactId>
            <version>2.6.1</version>
            <type>jar</type>
            <jar>xerces-2.6.1.jar</jar>
            <properties/>
        </dependency>
		...
    </dependencies>
	...

All help and suggestions are much appreciated.

Cheers!
sinclair


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message