maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Christian Mouttet <christian.mout...@keller-verlag.de>
Subject Re: Maven shared via Samba-Share
Date Thu, 05 Aug 2004 07:08:07 GMT
Brett,

here comes the output of 'maven -X -e'.  'maven --info' prints the same
lines.

--%<--
 __  __
|  \/  |__ _Apache__ ___
| |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
|_|  |_\__,_|\_/\___|_||_|  v. 1.0

Initializing Plugins!
org.apache.maven.MavenException: Maven was badly installed. Please
reinstall it.
        at
org.apache.maven.plugin.PluginManager.initialize(PluginManager.java:240)
        at
org.apache.maven.MavenSession.initializePluginManager(MavenSession.java:207)
        at
org.apache.maven.MavenSession.initialize(MavenSession.java:174)
        at org.apache.maven.cli.App.doMain(App.java:473)
        at org.apache.maven.cli.App.main(App.java:1215)
        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
        at
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
        at
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
        at java.lang.reflect.Method.invoke(Method.java:324)
        at com.werken.forehead.Forehead.run(Forehead.java:551)
        at com.werken.forehead.Forehead.main(Forehead.java:581)

You have encountered an unknown error running Maven. Please help us to
correct
this problem by following these simple steps:
- read the Maven FAQ at http://maven.apache.org/faq.html
- run the same command again with the '-e' parameter, eg maven -e jar
- search the maven-user archives for the error at
http://nagoya.apache.org/eyebrowse/SummarizeList?listName=users@maven.apache.org
- post the output of maven -e to JIRA at
http://jira.codehaus.org/BrowseProject.jspa?id=10030 (you must sign up
first)
- run 'maven --info' and post the output as the environment to the bug
above


Final Memory: 0M/1M
Total time: 18 seconds
Finished at: Thu Aug 05 08:58:30 CEST 2004
--%<--

I think this doen't help you very much.

Regards

-Christian


Am Mi, den 04.08.2004 schrieb Brett Porter um 22:19:
> could be a bug... can you send the output of -X?
> 
> Thanks,
> Brett
> 
> On Wed, 04 Aug 2004 17:00:15 +0200, Christian Mouttet
> <christian.mouttet@keller-verlag.de> wrote:
> > Hi Brett,
> > 
> > thank's for your answer. I don't exactly understand what plugins
> > directory are you talking about. Is it the 'plugins' directory that was
> > untar'ed out of 'maven-1.0.tar.gz'? This directory isn't empty - there
> > are plugin-jars.
> > 
> > With Maven-1.0-rc I had a directory 'plugins' under $HOME/.maven
> > (%USERPROFILE%\.maven). The final release uses cache to hold the
> > unjar'ed plugins.
> > 
> > Regards
> > 
> > -Christian
> > 
> > >Date: Fri, 30 Jul 2004 10:11:22 -0400
> > >From: Brett Porter <brett.porter@gmail.com>
> > >Subject: Maven shared via Samba-Share
> > >Content-Type: text/plain; charset=US-ASCII
> > 
> > 
> > >
> > >this error appears when the plugins directory is empty. The message
> > >should be improved I think.
> > >
> > 
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> > For additional commands, e-mail: users-help@maven.apache.org
> > 
> >
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message