maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <brett.por...@gmail.com>
Subject Re: Deploying snapshot to a repository running windows.
Date Fri, 02 Jul 2004 03:24:57 GMT
if you are using Maven RC4, specify the properties to the artifact plugin
http://maven.apache.org/reference/plugins/artifact/
This is a an alternate deploy method that won't do a symlink.

Alternatively, you could try -Dmaven.artifact.legacy=false and see if
that works with your current properties. It tries to convert as many
as possible, but YMMV.

- Brett

On Thu, 01 Jul 2004 20:53:53 -0400, Paul Spencer <paulsp@apache.org> wrote:
> 
> My central maven repository is on a windows machine.  The goal
> jar:snapshot-deploy write a number of files including the snapshot files
> with timestamps.  I expected the file artifact-SNAPSHOT.jar, but
> artifact-SNAPSHOT.jar.lnk was written instead.  The problem is when a
> maven project tries to retrieve the snapshot, it is not found.
> 
> Any suggestions (short of moving the repository to unix)?
> 
> FYI:
>    OS - Windows 2000
>    Web Server - Apache 1.3.24
>    SSH - OpenSSH_3.5p1 from cygwin
> 
> Paul Spencer
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
> 
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message