maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carlos Sanchez" <apa...@carlos.cousas.net>
Subject RE: Multiproject build failure
Date Fri, 02 Jul 2004 15:34:48 GMT
Hi,

Look for a incorrect dependency. Try moving away project folders until it
works.

Regards

Carlos Sanchez
A Coruña, Spain

Oness Project
http://oness.sourceforge.net
 

> -----Original Message-----
> From: STRAYER, JON (SBCSI) [mailto:js6285@sbc.com] 
> Sent: Friday, July 02, 2004 3:56 PM
> To: 'Maven Users List'
> Subject: Multiproject build failure
> 
> I'm in the process of splitting a project up into several 
> subprojects.  I've been running the multiproject build for 
> weeks without problems.  I just changed the subprojects so 
> they extend the main project.  Each subproject builds fine, 
> but now when I run multiproject I get this error message:
> 
> multiproject:projects-init:
>     [echo] Gathering project list
> Starting the reactor...
> 
> BUILD FAILED
> File......
> /home/wfausers/wfaoper/.maven/cache/maven-multiproject-plugin-
> 1.3.1/plugin.j
> elly
> Element... maven:reactor
> Line...... 63
> Column.... 9
> A cycle has been detected from the initial goal 
> [wfa-billing:core] Total time: 21 seconds Finished at: Fri 
> Jul 02 08:11:35 CDT 2004
> 
> How can I go about finding the cycle it's complaining about?
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
> 
> 
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message