maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Paul Spencer <pau...@apache.org>
Subject Re: javadoc:deploy failure
Date Fri, 11 Jun 2004 19:47:32 GMT
Danial,

Try connecting via ssh.  Using the command below, it should prompt for a 
password.

   ssh -l my_username www.matrix.ch

Some notes from my experience:
1) When using the property maven.repo.x.privatekey, you must also set 
maven.repo.x.passphrase.

2) I found setting maven.deployer.scp.compress to false helped.

3) site:deploy did not work on maven-rc2.  It works with rc3

 From my build.properties, but these entries can also be in 
project.properties:
   # Common Remote repository definitions
   maven.repo.foo=scp://developer.foo.com
   maven.repo.foo.compress=false
   maven.repo.foo.privatekey=/cygwin/home/my_username/.ssh/id_rsa
   maven.repo.foo.passphrase=
   maven.repo.foo.username=my_username
   maven.deployer.scp.compress=false

 From project.properties
   # Common Remote repository definitions
   maven.repo.list=foo
   maven.repo.foo=scp://developer.foo.com
   maven.repo.foo.directory=/cygdrive/f/Maven-Repository
   maven.repo.foo.group=maven

FYI:
   Client platform: Windows XP, Maven 1.0-rc3, jdk 1.4
   Server platform: windows 2000, cygwin for ssh and scp


Paul Spencer

Daniel Frey wrote:

> The artifact plugin specifies to set up a repo. I did:
> 
>     maven.repo.list = xmatrix
>     maven.repo.xmatrix = scp://www.xmatrix.ch
>     maven.repo.xmatrix.directory = /my/maven/repository
>     maven.repo.xmatrix.username = my_username
>     maven.repo.xmatrix.password = my_password
> 
> And I still get the same error. maven -X javadoc:deploy does not feedback
> the exact problem. I just get:
> 
>     Will deploy to 1 repository(ies): xmatrix
>     Deploying to repository: xmatrix
>     host: 'www.xmatrix.ch'
>     com.jcraft.jsch.JSchException: Auth fail
> 
> Is there a way to get a more detailed debug message?
> 
> Thanks
> Daniel Frey
> 
> 
>>From: Emmanuel Venisse <emmanuel@venisse.net>
>>Subject: javadoc:deploy failure
>>Date: Thu, 10 Jun 2004 14:16:07 +0200
>>Content-Type: text/plain;
>>	charset="iso-8859-1"
>>
>>javadoc:deploy goal use the artifact plugin
>>(http://maven.apache.org/reference/plugins/artifact/) and the jar:deploy
>>goal use the deploy plugin.
>>
>>You must set properties diffently for this txo plugins.
>>
>>Emmanuel
>>
>>----- Original Message ----- 
>>From: "Daniel Frey" <daniel.frey@xmatrix.ch>
>>To: "'Maven Users List'" <users@maven.apache.org>
>>Sent: Thursday, June 10, 2004 12:52 PM
>>Subject: javadoc:deploy failure
>>
>>
>>
>>>Hello
>>>
>>>I try to deploy javadoc to the repository without success:
>>>
>>>    maven -X javadoc:deploy
>>>    ...
>>>    Will deploy to 1 repository(ies): xmatrix
>>>    Deploying to repository: xmatrix
>>>    host: 'www.xmatrix.ch'
>>>    Failed to deploy to: xmatrix Reason: Cannot connect. Reason: Auth
> 
> fail
> 
>>>I don't understand that, and the debug feedback is sparesly. Deployment
> 
> of
> 
>>>the jars work perfect (maven jar:deploy). Do you see any hint you can
> 
> give
> 
>>>me to solve that problem?
>>>
>>>Thanks
>>>Daniel Frey
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
> 
> 



---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message