maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Winston.R...@jeppesen.com
Subject RE: RC3 Property Inheritance Problem
Date Thu, 27 May 2004 15:13:21 GMT


Thanks Brett. I followed my mistakenly missing attachment with another post but
for some reason it never made it to the list. I created MAVEN-1296 in JIRa for
the issue. Hope you can get the chance to look at this as it is pretty important
in my view.
-wr





Brett Porter <bporter@f2network.com.au> on 05/26/2004 05:08:56 PM

Please respond to "Maven Users List" <users@maven.apache.org>

To:   "'Maven Users List'" <users@maven.apache.org>
cc:    (bcc: Winston Rast/Jeppesen/TMC)

Subject:  RE: RC3 Property Inheritance Problem



Attachement is not there.

Can you post the contents of your message to JIRA and attach the example?

Thanks,
Brett

> -----Original Message-----
> From: Winston.Rast@jeppesen.com [mailto:Winston.Rast@jeppesen.com]
> Sent: Thursday, 27 May 2004 7:36 AM
> To: users@maven.apache.org
> Subject: Re: RC3 Property Inheritance Problem
>
>
>
>
> I've been doing a lot of trial and error with this problem
> and I've narrowed it down to what I think is a problem in
> multiproject environments with inherited properties. It is
> *not* an issue strictly with the maven.compile.* properties
> as I've previously mentioned. I'm attaching a jar file of my
> stripped down example to demonstrate. In my example, I'm
> demonstrating the problem with the maven.repo.remote
> property. To replicate the problem, do the following:
>
> * Edit project.properties under test/ and change
> maven.repo.remote to something other than ibiblio.
> * Edit test/service/myservice/ejb/project.xml with a
> dependency (something NOT on ibiblio, but on the remote repo
> specified previously)
> * Remove this dependent jar from your local repository so
> it's forced to download it again
> * From test/service/myservice, execute a maven goal (I
> generally do clean)
>
> This should fail to download. Strangely, if I run the same
> maven goal from test/service/myservice/ejb, it DOES download!
> Anyone have a clue what's happening here?
>
> -wr
>
> ______________________________________________________________
> ____________________________________
> NOTICE:  This communication and any files transmitted with it
> ("communication") may contain privileged or other
> confidential information. This communication is intended
> solely for the individual or entity to whom it is addressed.
> If you are not the intended recipient, or believe that you
> have received this communication in error, please do not
> print, copy, retransmit, disseminate, or otherwise use this
> communication.  Also, please indicate to the sender that you
> have received this communication in error, and then delete
> this communication and any copies. Thank you.
>
>
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>








---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message