maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From nicolas De Loof <nicolas.del...@cgey.com>
Subject Re: having troubles with maven RC2
Date Wed, 24 Mar 2004 14:00:29 GMT
I tryied the 3 cactus-maven-plugin versions that I found on ibiblio. 
Using 1.6dev-20040115, eclipse plugin works fine. with the 2 newers one, 
I got this ClassNotFoundException.

Is this a known bug ? Iis it any "api change" in cactus plugin that 
causes this exception ? Do I need to open a new bug for this ?

Nico.

nicolas De Loof a écrit :

> OK about that, but didn't maven dependency ensure this when runing the 
> eclipse plugin ?
>
> I re-installed maven RC2 and deleted my local repo for test.
>
> without the cactus plugin, eclipse:generate-classpath goal works fine
> with cactus plugin 1.6dev-20040226, I get this ClassNotFoundException
>
> Do I need to use and earlier cactus plugin version ?
>
> Nico.
>
> Barbier Gabriel a écrit :
>
>> this jar must be place in your folder 
>> ${MAVEN_HOME_LOCAL}/repository/commons-jelly/jars/ and not in folder 
>> where maven is installed.
>>
>> -----Message d'origine-----
>> De : nicolas De Loof [mailto:nicolas.deloof@cgey.com]
>> Envoyé : mercredi 24 mars 2004 14:46
>> À : Maven Users List
>> Objet : having troubles with maven RC2
>>
>>
>> Hello,
>>
>> I'm trying to use maven RC2 on some of our projects that are using RC1.
>>
>> Everything looks good (build, test, cactus with new cactus-maven 
>> plugin...), but I get some troubles with maven-eclipse plugin :
>>
>> maven eclipse:generate-classpath fails with this error :
>>
>> __  __
>> |  \/  |__ _Apache__ ___
>> | |\/| / _` \ V / -_) ' \  ~ intelligent projects ~
>> |_|  |_\__,_|\_/\___|_||_|  v. 1.0-rc2
>>
>> Could not find the class: 
>> org.apache.commons.jelly.tags.xml.XMLTagLibrary
>> java.lang.ClassNotFoundException: 
>> org.apache.commons.jelly.tags.xml.XMLTagLibrary
>>    at java.net.URLClassLoader$1.run(URLClassLoader.java:199)
>> ....
>>
>>
>> I added  commons-jelly-tags-xml-20030211.142705.jar to my 
>> ${maven-home}/bin and it works....
>> Has it been omitted from mavenRC2 dist or are eclipse-plugin 
>> dependencies broken with RC2 ?
>>
>> I used windows Exe installer to get maven RC2.
>>
>> Nico.
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
>> For additional commands, e-mail: users-help@maven.apache.org
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
>> For additional commands, e-mail: users-help@maven.apache.org
>>
>>  
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
>

---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message