maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <bpor...@f2network.com.au>
Subject RE: Building from current CVS head
Date Wed, 03 Dec 2003 02:17:51 GMT
    <antcall target="clean-maven-home"/>

    <copy todir="${maven.home}">
      <fileset dir="${maven.bootstrap.install.dir}">
        <exclude name="plugins/**" />
      </fileset>
    </copy>

    <!-- expanded plugins should be put in the maven.home.local -->
    <copy todir="${maven.home.local}">
      <fileset dir="${maven.bootstrap.install.dir}">
        <include name="plugins/**" />
      </fileset>
    </copy>

It puts them straight back again.

What is in ls bootstrap/install-phase1/plugins/ ?


> -----Original Message-----
> From: Sverre Eplov [mailto:sverre@explicit.dk] 
> Sent: Wednesday, 3 December 2003 1:09 PM
> To: Maven Users List
> Subject: RE: Building from current CVS head
> 
> 
> Linux, Sun JDK 1.4.2_02, Ant 1.5.4
> 
>  I haven't had any problems up to now, I've been using maven 
> for a while and since I'm talking loud and wide about all 
> it's niceties, I've always used the most current CVS version.
> 
> I just tried the same setup as you, still get the same error.
> 
> One thing I don't get: a "clean-maven-home" ant target is 
> executed just before the building plugins are attempted. This 
> will clear both maven.home/plugins and 
> maven.home.local/plugins. Where are the plugins which maven 
> will use during the build of the plugins themselves supposed 
> to be located ? 
> 
> br,
>   /Sverre
> 
> On Wed, 2003-12-03 at 03:03, Brett Porter wrote:
> > As the email said, windows with cygwin. This is effectively 
> the same 
> > as Windows as it translates the paths and then runs as usual. Same 
> > results on Solaris.
> > 
> > It should be MAVEN_HOME_LOCAL.
> > 
> > What env are you using?
> > 
> > - Brett
> > 
> > > -----Original Message-----
> > > From: Sverre Eplov [mailto:sverre@explicit.dk]
> > > Sent: Wednesday, 3 December 2003 12:57 PM
> > > To: Maven Users List
> > > Subject: RE: Building from current CVS head
> > > 
> > > 
> > > Nope - same problem with different settings for MAVEN_HOME
> > > and MAVEN_LOCAL_HOME.
> > > 
> > > What platform are you using ?
> > > 
> > > br,
> > >   /Sverre
> > > 
> > > 
> > > 
> --------------------------------------------------------------------
> > > -
> > > To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> > > For additional commands, e-mail: users-help@maven.apache.org
> > > 
> -- 
> /Sverre Eplov
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
> 

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message