maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From d...@multitask.com.au
Subject RE: Artifact:deploy succeeds, but does not copy via scp
Date Thu, 27 Nov 2003 23:22:33 GMT
jar:deploy uses another mechanism because artifact:deploy isn't finished 
or tested.

It'd be better if they all used something that worked.
--
dIon Gillard, Multitask Consulting
Blog:      http://blogs.codehaus.org/people/dion/



<egglersim@post.ch> wrote on 27/11/2003 09:44:24 PM:

> Ant how come the jar:deploy goal uses another mechanism?
> 
> Has anybody tried this under windouze? 
> 
> -----Original Message-----
> From: Michal Maczka [mailto:mmaczka@interia.pl] 
> Sent: Donnerstag, 27. November 2003 11:30
> To: Maven Users List
> Subject: Re: Artifact:deploy succeeds, but does not copy via scp
> 
> 
> egglersim@post.ch wrote:
> 
> >When calling artifact:deploy, the build project finishes with BUILD 
> SUCCESSFUL, but on the remote host, i cannot find the deployed artifact.
> >
> >Here's my call:
> >
> >C:\hans-maven\modules\ueli>maven ejb:deploy
> >.
> >.
> >.
> >ejb:ejb:
> >    [echo] Building ejb ueli-1.0
> >    [jar] Building jar: C:\hans-maven\modules\ueli\target\ueli-1.0.jar
> >Will deploy to 1 repository(ies): belleville
> >Deploying to repository: belleville
> >host: 'belleville'
> >Deploying: 
C:\hans-maven\modules\ueli\project.xml-->hans/poms/ueli-1.0.pom
> >Deploying: 
C:\hans-maven\modules\ueli\project.xml.md5-->hans/poms/ueli-1.0.pom.md5
> >Will deploy to 1 repository(ies): belleville
> >Deploying to repository: belleville
> >host: 'belleville'
> >Deploying: 
C:\hans-maven\modules\ueli\target\ueli-1.0.jar-->hans/ejbs/ueli-1.0.jar
> >Deploying: C:\hans-maven\modules\ueli\target\ueli-1.0.jar.
> md5-->hans/ejbs/ueli-1.0.jar.md5
> >BUILD SUCCESSFUL
> >Total time: 20 seconds
> >Finished at: Thu Nov 27 10:39:45 CET 2003
> >
> >
> >
> >And the build.properties:
> >
> >maven.repo.list=belleville
> >maven.repo.belleville=scp://belleville
> >maven.repo.belleville.directory=habakus
> >maven.repo.belleville.username=henä
> >maven.repo.belleville.password=hubub
> >
> >
> >My environment: 
> >W2k workstation, jdk 1.4.2, maven rc1, ant 1.5.4
> >
> >
> >What's wrong?
> >
> >Cheers,
> >simon
> > 
> >
> Can you please try with sftp (just another protocol from SSH family)?
> I think that it might becouse I have used some unix commands which maybe 

> are not working for you.
> (I have briefly tested it with freebsd and linux)
> 
> Michal
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
> For additional commands, e-mail: users-help@maven.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message