maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Siegfried Göschl" <siegfried.goes...@it20one.at>
Subject RE: installing maven
Date Tue, 26 Aug 2003 20:11:20 GMT
Actually you should use the JDK directory since MAVEN needs access to 
javac and javadoc

Cheers,

Siegfried Goeschl

On 26 Aug 2003 at 11:10, Thakkar, Hetal wrote:

> JAVA_HOME is set to "c:\J2SDK_Forte\jdk1.4.0\jre", where the bin and
> lib directory for java are.
> 
> Thanks,
> Hetal
> 
> -----Original Message-----
> From: dion@multitask.com.au [mailto:dion@multitask.com.au]
> Sent: Monday, August 25, 2003 8:05 PM
> To: Maven Users List
> Subject: RE: installing maven
> 
> 
> Is JAVA_HOME set?
> --
> dIon Gillard, Multitask Consulting
> Blog:      http://blogs.codehaus.org/people/dion/
> 
> 
> "Thakkar, Hetal" <hetal.thakkar@citigroup.com> wrote on 26/08/2003
> 02:44:59 AM:
> 
> > I have not specified any urls any where. I am just trying to run
> > maven, out of the box.
> > 
> > Thanks,
> > Hetal
> > 
> > -----Original Message-----
> > From: Trygve Laugstøl [mailto:trygvela@student.matnat.uio.no]
> > Sent: Sunday, August 24, 2003 4:40 AM
> > To: Maven Users List
> > Subject: Re: installing maven
> > 
> > 
> > On Fri, 22 Aug 2003, Thakkar, Hetal wrote:
> > 
> > > I am running in to the following problem while trying to install 
> maven.
> > >
> > > I downloaded the Maven zip file and extracted it.
> > > I also setup the MAVEN_HOME and PATH variables.
> > >
> > > But I cannot run the %MAVEN_HOME%\bin\install_repo.bat
> > > %HOME%\.maven\repository command since install_repo.bat does not 
> exist.
> > > I am not sure what is going wrong. Also, two days back on 20th the
> > > instructions were different for installing then now.
> > >
> > > If I try to run maven without running the install_repo.bat then I
> > > get the following error, regardless of the parameters passed to
> > > maven: java.net.MalformedURLException: unknown protocol: c
> > >         at java.net.URL.<init>(URL.java:586)
> > >         at java.net.URL.<init>(URL.java:476)
> > >         at java.net.URL.<init>(URL.java:425)
> > >         at 
> com.werken.forehead.Forehead.loadFileOrUrl(Forehead.java:401)
> > >         at com.werken.forehead.Forehead.load(Forehead.java:322) at
> > >         com.werken.forehead.Forehead.config(Forehead.java:245) at
> > >         com.werken.forehead.Forehead.config(Forehead.java:131) at
> > >         com.werken.forehead.Forehead.main(Forehead.java:571)
> > >
> > > Could this be because I am behind a firewall?
> > >
> > > Any suggestions will be appriciated.
> > >
> > > Thanks,
> > > Hetal
> > >
> > 
> > This is because you have specified a url as 'c:\...' and the format
> > of a url is 'protocoll:', so it is interpreted a the protocoll 'c'
> > (as the exception says)
> > 
> > What you want is to say that you want to specify a file url, thus:
> > 'file://c:/'
> > 
> > I'm not sure if 'file:c:/' is the actual right way, but the first 
> variant
> > always works for me :)
> > 
> > Trygvis
> > 
> > --------------------------------------------------------------------
> > - To unsubscribe, e-mail: users-unsubscribe@maven.apache.org For
> > additional commands, e-mail: users-help@maven.apache.org
> > 
> > --------------------------------------------------------------------
> > - To unsubscribe, e-mail: users-unsubscribe@maven.apache.org For
> > additional commands, e-mail: users-help@maven.apache.org
> > 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: users-unsubscribe@maven.apache.org For
> additional commands, e-mail: users-help@maven.apache.org
> 






---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message