maven-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Luke Taylor <nega...@freesurf.ch>
Subject Re: "Unsatisfied dependencies" for reactor dependencies in Beta 9
Date Wed, 02 Jul 2003 00:05:28 GMT
Ext-Mike.Hogan@nokia.com wrote:

>>>This works for beta 8 but not beta 9.  What ya reckon?
>>

It looks like the dependency problem is between your "toplevel" project 
code and one of the subprojects ("base"). Since the reactor works out 
dependencies between the subprojects it's being run on I don't think it 
can help you here. It may have worked OK in the past because of some 
coincidence in the order in which Maven attempted to resolve the 
dependencies - it may have done the reactor build before attempting to 
download the base-1.0.jar or something.

Probably your best bet would be to make the current "toplevel" module 
part of the same reactor build if possible, extending all the 
project.xmls from a new root one.

Luke.

-- 
  Luke Taylor.                      Monkey Machine Ltd.
  PGP Key ID: 0x57E9523C            http://www.monkeymachine.ltd.uk




---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@maven.apache.org
For additional commands, e-mail: users-help@maven.apache.org


Mime
View raw message