maven-surefire-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Igor Petruk <Igor_Pet...@epam.com>
Subject RE: surefire-junit47 provider does not see my tests (while older one does but fails)
Date Wed, 20 Apr 2011 08:10:30 GMT
Now my config looks like this

                               <plugin>
                                       <groupId>org.apache.maven.plugins</groupId>
                                        <artifactId>maven-surefire-plugin</artifactId>
                                        <version>2.8.1</version>
                                            <dependencies>
                                                  <dependency>
                                                        <groupId>org.apache.maven.surefire</groupId>
                                                        <artifactId>surefire-junit47</artifactId>
                                                        <version>2.8.1</version>
                                                  </dependency>
                                                </dependencies>

                                        <configuration>
                                                <includes>
                                                        <include>**/Test*.java</include>
                                                        <include>**/*Test.java</include>
                                                        <include>**/*TestCase.java</include>
                                                </includes>
                                <!--            <excludes>
                                                        <exclude>**/manual/**</exclude>
                                                </excludes>
-->
                                                <argLine>-Xmx1024m -XX:MaxPermSize=128m</argLine>
                                        </configuration>
                                </plugin>

You can see an obvious copy-paste of includes from what should be enabled by default in documentation.
Still no good.

What I noticed from experimenting. I can make test run, but through "test" option and Spring's
"@RunWith(SpringJUnit4ClassRunner.class)" should be removed. These are the only options to
make tests run.

Mime
View raw message