maven-surefire-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ben Hsu" <>
Subject Spring messages are not showing up
Date Wed, 20 Jan 2010 15:45:21 GMT

[crossposting to the surefire and log4j mailing lists]


Hello everybody,


Can you help me with a problem? I am running surefire unit tests against
a spring application. I am trying to see the debug messages spring puts
out. The messages show up when I deploy the application into JBoss, but
when I run the surefire unit tests they don't show up.


Here is my surefire config from my pom.xml file:


         <!-- Surefire test runner plugin -->









              <!-- Specific log4j config for tests -->  








the log4j properties has this content:

log4j.rootLogger=TRACE, R



log4j.appender.R.layout.ConversionPattern=%d{ABSOLUTE} %5p %c{3}:%L -


and the -Dlog4j.debug produces this output:

log4j: Using URL [file:./src/main/config/] for
automatic log4j configuration.

log4j: Reading configuration from URL

log4j: Parsing for [root] with value=[TRACE, R].

log4j: Level token is [TRACE].

log4j: Category root set to TRACE

log4j: Parsing appender named "R".

log4j: Parsing layout options for "R".

log4j: Setting property [conversionPattern] to [%d{ABSOLUTE} %5p
%c{3}:%L - %m%n].

log4j: End of parsing for "R".

log4j: Parsed "R" options.

log4j: Finished configuring.


Thank you everybody.


  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message