maven-surefire-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From car...@apache.org
Subject svn commit: r395357 - /maven/surefire/trunk/pom.xml
Date Wed, 19 Apr 2006 19:12:54 GMT
Author: carlos
Date: Wed Apr 19 12:12:52 2006
New Revision: 395357

URL: http://svn.apache.org/viewcvs?rev=395357&view=rev
Log:
Added a profile to ignore JDK 1.3 requirements

Modified:
    maven/surefire/trunk/pom.xml

Modified: maven/surefire/trunk/pom.xml
URL: http://svn.apache.org/viewcvs/maven/surefire/trunk/pom.xml?rev=395357&r1=395356&r2=395357&view=diff
==============================================================================
--- maven/surefire/trunk/pom.xml (original)
+++ maven/surefire/trunk/pom.xml Wed Apr 19 12:12:52 2006
@@ -90,6 +90,7 @@
   </distributionManagement>
 
   <profiles>
+    <!-- use preinstalled JDK 1.3 to build and test -->
     <profile>
       <id>jdk1.3</id>
       <build>
@@ -112,6 +113,17 @@
         </plugins>
       </build>
     </profile>
+
+    <!-- ignore JDK 1.3 requirement for handy testing -->
+    <profile>
+      <id>ignoreJdk</id>
+    </profile>
+
+    <!-- print a warning when not using the JDK 1.3 profile, and prevent deployment
+         NOTE prevent deployment actually don't work as the deploy plugin is called
+         before the antrun in the deploy phase.
+         In multimodule the first module will be deployed and build will fail after
+    -->
     <profile>
       <id>nojdk1.3</id>
       <activation>
@@ -148,6 +160,8 @@
                     <echo>=== ERROR: You are not building with Java 1.3 as required
===</echo>
                     <echo>Set JAVA_1_3_HOME pointing to the JDK 1.3 installation folder</echo>
                     <echo>and run Maven with -Pjdk1.3 to activate the Java 1.3 profile</echo>
+                    <echo/>
+                    <echo>You could also run Maven with -PignoreJdk to use any JDK
version (be aware of the implications)</echo>
                     <echo/>
                     <fail>ERROR: You can not deploy without using Java  1.3.</fail>
                   </tasks>



Mime
View raw message