maven-scm-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Damon Rand <da...@cybermagic.co.nz>
Subject How do I force use of maven-scm-provider-gitexe v1.3?
Date Wed, 05 May 2010 00:40:50 GMT
Hi,

I'm trying to use 1.3 of the gitexe scm extension.. I've tried forcing
this in the extensions section..

                  <extensions>
                       <extension>
                   <groupId>org.apache.maven.wagon</groupId>
                   <artifactId>wagon-scm</artifactId>
                   <version>1.0-beta-6</version>
                       </extension>
                       <extension>
                         <groupId>org.apache.maven.scm</groupId>
                         <artifactId>maven-scm-manager-plexus</artifactId>
                         <version>1.3</version>
                       </extension>
                       <extension>
                         <groupId>org.apache.maven.scm</groupId>
                         <artifactId>maven-scm-provider-svnexe</artifactId>
                         <version>1.1</version> <!-- Nothing above 1.1
works for me right now -->
                       </extension>
                       <extension>
                         <groupId>org.apache.maven.scm</groupId>
                         <artifactId>maven-scm-provider-gitexe</artifactId>
                         <version>1.3</version>
                       </extension>

And in plugin dependencies..

<plugins>
        <plugin>
          <groupId>org.apache.maven.plugins</groupId>
          <artifactId>maven-scm-plugin</artifactId>
          <version>1.3</version>
          <extensions>true</extensions>
          <dependencies>
            <dependency>
              <groupId>org.apache.maven.scm</groupId>
              <artifactId>maven-scm-providers</artifactId>
              <version>1.3</version>
            </dependency>
            <dependency>
              <groupId>org.apache.maven.scm</groupId>
              <artifactId>maven-scm-provider-gitexe</artifactId>
              <version>1.3</version>
            </dependency>
            <dependency>
              <groupId>org.apache.maven.scm</groupId>
              <artifactId>maven-scm-provider-git-commons</artifactId>
              <version>1.3</version>
            </dependency>
          </dependencies>
        </plugin>
      </plugins>

But no matter what I do it uses 1.1 which has a bug..

Any ideas?

Regards,
Damon.

Mime
View raw message