maven-scm-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mohammad Nour El-Din" <nour.moham...@gmail.com>
Subject Re: Help with the scm cvs plugin
Date Sat, 02 Jun 2007 17:33:43 GMT
Hi Emmanuel...

My account on that server is restricted account and I can not copy anything
to there :(. Any other way to accomplish this ???

On 6/1/07, Emmanuel Venisse <emmanuel@venisse.net> wrote:
>
> You don't need admin access.
> create public and private key on your machine
> copy the private key under your .ssh directory
> copy your public key under you $HOME/.ssh on the server
>
> Emmanuel
>
> Mohammad Nour El-Din a écrit :
> > Yeah I read about this, but what if I don't have administration access
> > to the server I connect to ?
> >
> > On 6/1/07, *Emmanuel Venisse* < emmanuel@venisse.net
> > <mailto:emmanuel@venisse.net>> wrote:
> >
> >     The best way is to use ssh key, you'll find lot of tutorial about
> >     how to create them with Google
> >
> >     Mohammad Nour El-Din a écrit :
> >      > Thats good, but is there anyway to make the scm plugin or cvs
> >     itself to
> >      > pass this password to the ssh so it does not prompt me for the
> >     password.
> >      > I need to automate the checkout process during the build life
> >     cycle, and
> >      > making someone waiting there to enter the password will make the
> >     whole
> >      > process not automated. Please advice.
> >      >
> >      > On 5/30/07, *Emmanuel Venisse* <emmanuel@venisse.net
> >     <mailto:emmanuel@venisse.net>
> >      > <mailto:emmanuel@venisse.net <mailto:emmanuel@venisse.net>>>
> wrote:
> >      >
> >      >     When you use cvs over ssh (with ext protocol), cvs doesn't
> have a
> >      >     password, it's the ssh connection that require an
> >     authentication and
> >      >     we don't have the hand on it.
> >      >
> >      >     Emmanuel
> >      >
> >      >     Mohammad Nour El-Din a écrit :
> >      >      > One more question, why the password configuration
> >     parameter is not
> >      >      > passed to the cvs command ?
> >      >      >
> >      >      > On 5/30/07, *Emmanuel Venisse* < emmanuel@venisse.net
> >     <mailto:emmanuel@venisse.net>
> >      >     <mailto:emmanuel@venisse.net <mailto:emmanuel@venisse.net>
>
> >      >      > <mailto:emmanuel@venisse.net <mailto:emmanuel@venisse.net>
> >     <mailto:emmanuel@venisse.net <mailto:emmanuel@venisse.net>>>>
wrote:
> >      >      >
> >      >      >     yes
> >      >      >
> >      >      >     Mohammad Nour El-Din a écrit :
> >      >      >      > Hi Emmanuel...
> >      >      >      >
> >      >      >      > But this totally an ssh matter, right ?
> >      >      >      >
> >      >      >      > On 5/30/07, *Emmanuel Venisse* <
> >     emmanuel@venisse.net <mailto:emmanuel@venisse.net>
> >      >     <mailto:emmanuel@venisse.net <mailto:emmanuel@venisse.net>>
> >      >      >     <mailto: emmanuel@venisse.net
> >     <mailto:emmanuel@venisse.net> <mailto:emmanuel@venisse.net
> >     <mailto:emmanuel@venisse.net>>>
> >      >      >      > <mailto: emmanuel@venisse.net
> >     <mailto:emmanuel@venisse.net>
> >      >     <mailto:emmanuel@venisse.net <mailto:emmanuel@venisse.net>>
> >     <mailto:emmanuel@venisse.net <mailto:emmanuel@venisse.net>
> >      >     <mailto: emmanuel@venisse.net
> >     <mailto:emmanuel@venisse.net>>>>> wrote:
> >      >      >      >
> >      >      >      >     You must use a ssh agent or a private/public
> >     ssh key
> >      >      >      >
> >      >      >      >     Emmanuel
> >      >      >      >
> >      >      >      >     Mohammad Nour El-Din a écrit :
> >      >      >      >      > Hi All...
> >      >      >      >      >
> >      >      >      >      > I working on something at my project, and
I
> am
> >      >     using the
> >      >      >     scm cvs
> >      >      >      >     plugin.
> >      >      >      >      > It works fine but for one thing, I provide
> the
> >      >     password
> >      >      >     into the
> >      >      >      >      > configuration section, but while running
the
> >     build
> >      >     the ssh
> >      >      >      >     prompts me to
> >      >      >      >      > enter the password. I tried a lot of things
> >     even to
> >      >      >     redirect the
> >      >      >      >     input
> >      >      >      >      > to take the parameter from a file and it
> >     didn't work.
> >      >      >     Please help.
> >      >      >      >      >
> >      >      >      >      > --
> >      >      >      >      > Thanks
> >      >      >      >      > - Mohammad Nour
> >      >      >      >
> >      >      >      >
> >      >      >      >
> >      >      >      >
> >      >      >      > --
> >      >      >      > Thanks
> >      >      >      > - Mohammad Nour
> >      >      >
> >      >      >
> >      >      >
> >      >      >
> >      >      > --
> >      >      > Thanks
> >      >      > - Mohammad Nour
> >      >
> >      >
> >      >
> >      >
> >      > --
> >      > Thanks
> >      > - Mohammad Nour
> >
> >
> >
> >
> > --
> > Thanks
> > - Mohammad Nour
>
>


-- 
Thanks
- Mohammad Nour

Mime
View raw message