maven-scm-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jackson, Brian R" <Brian.R.Jack...@espn3.com>
Subject RE: Perforce login
Date Mon, 25 Jun 2007 12:43:29 GMT
The problem was that I was missing a colon after the port number in the
connection URL.

 

Thank you for the response though.

 

Brian

 

________________________________

From: scm-users-return-158-Brian.R.Jackson=espn3.com@maven.apache.org
[mailto:scm-users-return-158-Brian.R.Jackson=espn3.com@maven.apache.org]
On Behalf Of Yuri Schimke
Sent: Monday, June 25, 2007 2:06 AM
To: scm-users@maven.apache.org
Subject: Re: Perforce login

 

Hey,

I don't think this is documented well enough, but apart from the release
process which uses a temporary client spec, you really need everything
to be working from the command line already.  This means having a local
checkout and a clientspec that uses the correct root for that checkout. 

It may very well be an issue with login, but its worth checking this as
well.

I was getting similar errors with my projects until I made sure that
from the command line e.g. DOS prompt, you can run 

p4 sync ...

The easiest way to ensure this works is to setup a p4.config file

http://www.perforce.com/perforce/doc.042/manuals/cmdref/env.P4CONFIG.htm
l 

On 6/21/07, Jackson, Brian R <Brian.R.Jackson@espn3.com> wrote:

I'm attempting to run "mvn scm:update" on my project but I get the
following output:

 

------------------------------------------------------------------------
-----------------------------------------

C:\Projects\SuperPOMs\espn>mvn scm:update

[INFO] Scanning for projects...

[INFO] Searching repository for plugin with prefix: 'scm'.

[INFO]
------------------------------------------------------------------------
-

---

[INFO] Building The ESPN Super POM

[INFO]    task-segment: [scm:update] (aggregator-style)

[INFO]
------------------------------------------------------------------------
-

---

[INFO] [scm:update]

[INFO] Checkout working directory: C:\Projects\SuperPOMs\espn

[INFO] Executing: p4 -d C:\Projects\SuperPOMs\espn -p
sw-ct-perfor01c.dev.espn3.

com client -i

[ERROR] Provider message:

[ERROR] Unable to sync.  Are you logged in?

[ERROR] Command output:

[ERROR]

[INFO]
------------------------------------------------------------------------

[ERROR] BUILD ERROR

[INFO]
------------------------------------------------------------------------

[INFO] Command failed.Unable to sync.  Are you logged in?

[INFO]
------------------------------------------------------------------------

[INFO] For more information, run Maven with the -e switch

[INFO]
------------------------------------------------------------------------

[INFO] Total time: 3 seconds

[INFO] Finished at: Thu Jun 21 18:12:19 EDT 2007

[INFO] Final Memory: 5M/12M

[INFO]
------------------------------------------------------------------------

 

C:\Projects\SuperPOMs\espn>

------------------------------------------------------------------------
-----------------------------------------

 

 

Any idea what I'm doing wrong.  I've configured my username in my
pom.xml as such:

    <build>

        <plugins>

            <plugin>

                <artifactId>maven-idea-plugin</artifactId>

                <configuration>

                    <downloadSources>true</downloadSources>

                    <downloadJavadocs>true</downloadJavadocs>

                </configuration>

            </plugin>

            <plugin>

                <!-- All ESPN projects must deploy a JAR containing the
source files

                     to the repository.  This allows other developers to
use browse

                     the source files while developing

                     -->

                <artifactId>maven-source-plugin</artifactId>

            </plugin>

            <plugin>

                <artifactId>maven-scm-plugin</artifactId>

                <configuration>

                    <username>${scm.username}</username>

                    <password>${scm.password}</password>

                </configuration>

            </plugin>

        </plugins>

    </build>

 

And setup my scm info as such:

    <scm>

 
<connection>scm:perforce:${perforce.host}:${perforce.port}//vss_espneng/
Projects/SuperPOMs/espn</connection>

 
<developerConnection>scm:perforce:${perforce.host}:${perforce.port}//vss
_espneng/Projects/SuperPOMs/espn

        </developerConnection>

        <url>http://longurl... <http://longurl%E2%80%A6> </url>

    </scm>

 

The properties referenced are configured in my settings.xml:

 

 

    <profiles>

        <profile>

            <activation>

                <activeByDefault/>

            </activation>

            <id>espn3.profile.dev</id>

            <repositories>

                <repository>

                    <releases>

                        <updatePolicy>never</updatePolicy>

                    </releases>

                    <id>espn3</id>

                    <url>
http://example.corp.espn3.com/px/repository/espn3
<http://example.corp.espn3.com/px/repository/espn3> </url>

                </repository>

                <repository>

                    <id>espn3.snapshot</id>

                    <releases>

                        <enabled>false</enabled>

                    </releases>

                    <snapshots>

                        <enabled>true</enabled>

                        <updatePolicy>interval:30</updatePolicy>

                    </snapshots>

                    <url>http://
example.corp.espn3.com/px/repository/espn3.snapshot</url>

                </repository>

            </repositories>

            <properties>

                <scm.username>MYUSERNAME</scm.username>

                <scm.password>123456</scm.password>

        <perforce.host> example.dev.espn3.com
<http://example.dev.espn3.com> </perforce.host>

        <perforce.port>1234</perforce.port>

            </properties>

        </profile>

    </profiles>




-- 
Yuri Schimke 


Mime
View raw message