maven-scm-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lord.Quackstar" <lord.quacks...@gmail.com>
Subject Re: Any plans to fix/update maven-scm-provider-hg ?
Date Mon, 31 Jan 2011 00:13:20 GMT
Got it working today. Thanks for the update.

Some quick things
-Why does this not work when you put it in the <build><extensions> area?
-Will this work with other plugins that deploy like a source deploy?
-Shouldn't it url encode the username and password? My username has a @ symbol 
in it which breaks the url and the initial clone

Thanks again for the update,
Leon





________________________________
From: Olivier Lamy <olamy@apache.org>
To: scm-dev@maven.apache.org
Sent: Thu, January 20, 2011 5:32:39 PM
Subject: Re: Any plans to fix/update maven-scm-provider-hg ?

Hello,
Fixed in scm trunk you can use (note where the dependency is declared)

        <pluginManagement>
          <plugins>
            <plugin>
              <groupId>org.apache.maven.plugins</groupId>
              <artifactId>maven-site-plugin</artifactId>
              <version>3.0-beta-3</version>
              <dependencies>
                <dependency>
                  <groupId>org.apache.maven.scm</groupId>
                  <artifactId>maven-scm-api</artifactId>
                  <version>1.5-SNAPSHOT</version>
                </dependency>
                <dependency>
                  <groupId>org.apache.maven.scm</groupId>
                  <artifactId>maven-scm-provider-hg</artifactId>
                  <version>1.5-SNAPSHOT</version>
                </dependency>
              </dependencies>
            </plugin>
          </plugins>
        </pluginManagement>

And use this repo (until scm 1.5 is released ) :
https://repository.apache.org/content/groups/snapshots-group/

let us know if you still have issues.

2011/1/20 Lord.Quackstar <lord.quackstar@gmail.com>:
> Sorry for the delay, I sent this with another email address that wasn't
> subscribed.
>
> I have this in my POM
>     <build>
>         <extensions>
>             <extension>
>                 <groupId>org.apache.maven.wagon</groupId>
>                 <artifactId>wagon-webdav</artifactId>
>                 <version>1.0-beta-2</version>
>             </extension>
>             <extension>
>                 <groupId>org.apache.maven.scm</groupId>
>                 <artifactId>maven-scm-provider-hg</artifactId>
>                 <version>1.4</version>
>             </extension>
>             <extension>
>                 <groupId>org.apache.maven.wagon</groupId>
>                 <artifactId>wagon-scm</artifactId>
>                 <version>1.0-beta-7</version>
>             </extension>
>         </extensions>
>        ..
>     </build>
>
>     <reporting>
>         <plugins>
>             <!--JavaDoc setup-->
>             <plugin>
>                 <groupId>org.apache.maven.plugins</groupId>
>                 <artifactId>maven-javadoc-plugin</artifactId>
>                 <version>2.7</version>
>                 <configuration>
>                     <defaultAuthor>Leon Blakey</defaultAuthor>
>                     <defaultVersion>${project.version}</defaultVersion>
>                     <links>
>                         http://download.oracle.com/javase/6/docs/api
>                     </links>
>                 </configuration>
>             </plugin>
>         </plugins>
>     </reporting>
>
>     <distributionManagement>
>          ...
>         <snapshotRepository>
>             <id>maven-general-repo.googlecode.com</id>
>             <name>General Maven Repo on Google Code</name>
>             scm:hg:https://site.pircbotx.googlecode.com/hg
>             <uniqueVersion>false</uniqueVersion>
>         </snapshotRepository>
>         <site>
>             <id>maven-general-repo.googlecode.com</id>
>             scm:hg:https://site.pircbotx.googlecode.com/hg/
>         </site>
>     </distributionManagement>
>
>
> Leon
>
> ________________________________
> From: Olivier Lamy <olamy@apache.org>
> To: scm-dev@maven.apache.org
> Sent: Fri, January 14, 2011 4:27:51 PM
> Subject: Re: Any plans to fix/update maven-scm-provider-hg ?
>
> Hello
> Can you give more details ?
> version of wagon scm you are using in your pom ?
>
> 2011/1/13 Lord.Quackstar <lord.quackstar@gmail.com>:
>> It seems that the only way to use Mercurial in Maven is through
>> maven-scm-provider-hg. However there are so many problems that the plugin
>> is
>> unusable
>>
>> First, you have it being out of date. In Maven 2.2.1 it works somewhat (by
>> working I mean it detects that it exists and tries to use it), but in
>> Maven
>> 3.0.2 you get this:
>>
>>  Transfer error: org.apache.maven.scm.manager.NoSuchScmProviderException:
>> No
>> such provider: 'hg'.
>>
>> Second, you have the list command bug, which seems to affect even people
>> using hudsun. They were able to fix it by creating their own plugin, which
>> doesn't work with Maven-only installations. Following is the error message
>>
>> [INFO] [deploy:deploy {execution: default-deploy}]
>> [INFO] Retrieving previous build number from
>>  pircbotx.googlecode.com
>> [INFO] Removing
>> C:\DOCUME~1\Owner\LOCALS~1\Temp\wagon-scm1210107000.checkout\pir
>> cbotx\pircbotx\1.3-SNAPSHOT
>> [INFO] EXECUTING: cmd.exe /X /C "hg clone -r tip
>>
>>https://*SNIP*@site.pircbotx.googlecode.com/hg/maven2/snapshots/pircbotx/pircbotx/1.3-SNAPSHOT
>>T
>>
>>C:\DOCUME~1\Owner\LOCALS~1\Temp\wagon-scm1210107000.checkout\pircbotx\pircbotx\1.3-SNAPSHOT"
>>"
>> [INFO] EXECUTING: cmd.exe /X /C "hg locate"
>> [INFO] repository metadata for: 'snapshot pircbotx:pircbotx:1.3-SNAPSHOT'
>> could not be found on repository: pircbotx.googlecode.com, so will be
>> created Uploading:
>>
>>scm:hg:https://site.pircbotx.googlecode.com/hg/maven2/snapshots/pircbotx/pircbotx/1.3-SNAPSHOT/pircbotx-1.3-SNAPSHOT.jar
>>r
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] BUILD ERROR
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Error deploying artifact: Error listing repository: No such command
>> 'list'.
>>
>> (This is replicated on site:deploy as well).
>>
>> Third, you have the complete lack of documentation on using it. It took me
>> 3+ hours to get the results above; everything else kept erroring out as I
>> slipped further into dependency hell. None of the projects have docs on
>> how
>> to use this.
>>
>> Fourth, you have the abandonment of the user support mailing list (
>> http://mail-archives.apache.org/mod_mbox/maven-scm-users/ ). This is more
>> general to maven-scm, but does affect this plugin. The last email talks
>> about this very same problem, however it's been almost 2 months with no
>> response. Even for the past year none of the support questions have been
>> answered.
>>
>> ---
>>
>> Combined, this leads to a plugin that isn't usable at all and can mislead
>> people into thinking that it works. Are their any plans to update it? Are
>> their any plans to depreciate it?
>>
>> Thanks,
>> Leon
>>
>>
>
>
>
> --
> Olivier Lamy
> http://twitter.com/olamy
> http://www.linkedin.com/in/olamy
>
>
>



-- 
Olivier Lamy
http://twitter.com/olamy
http://www.linkedin.com/in/olamy



      
Mime
View raw message