maven-scm-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Lord.Quackstar" <lord.quacks...@gmail.com>
Subject Any plans to fix/update maven-scm-provider-hg ?
Date Thu, 13 Jan 2011 22:58:07 GMT
It seems that the only way to use Mercurial in Maven is through 
maven-scm-provider-hg. However there are so many problems that the plugin is 
unusable

First, you have it being out of date. In Maven 2.2.1 it works somewhat (by 
working I mean it detects that it exists and tries to use it), but in Maven 
3.0.2 you get this:


 Transfer error: org.apache.maven.scm.manager.NoSuchScmProviderException: No 
such provider: 'hg'.

Second, you have the list command bug, which seems to affect even people using 
hudsun. They were able to fix it by creating their own plugin, which doesn't 
work with Maven-only installations. Following is the error message

[INFO] [deploy:deploy {execution: default-deploy}]
[INFO] Retrieving previous build number from pircbotx.googlecode.com
[INFO] Removing C:\DOCUME~1\Owner\LOCALS~1\Temp\wagon-scm1210107000.checkout\pir    
cbotx\pircbotx\1.3-SNAPSHOT
[INFO] EXECUTING: cmd.exe /X /C "hg clone -r tip 
https://*SNIP*@site.pircbotx.googlecode.com/hg/maven2/snapshots/pircbotx/pircbotx/1.3-SNAPSHOT
C:\DOCUME~1\Owner\LOCALS~1\Temp\wagon-scm1210107000.checkout\pircbotx\pircbotx\1.3-SNAPSHOT"
"
[INFO] EXECUTING: cmd.exe /X /C "hg locate"
[INFO] repository metadata for: 'snapshot pircbotx:pircbotx:1.3-SNAPSHOT' could 
not be found on repository: pircbotx.googlecode.com, so will be created 
Uploading: 
scm:hg:https://site.pircbotx.googlecode.com/hg/maven2/snapshots/pircbotx/pircbotx/1.3-SNAPSHOT/pircbotx-1.3-SNAPSHOT.jar

[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error deploying artifact: Error listing repository: No such command 
'list'.
(This is replicated on site:deploy as well). 

Third, you have the complete lack of documentation on using it. It took me 3+ 
hours to get the results above; everything else kept erroring out as I slipped 
further into dependency hell. None of the projects have docs on how to use this.

Fourth, you have the abandonment of the user support mailing list ( 
http://mail-archives.apache.org/mod_mbox/maven-scm-users/ ). This is more 
general to maven-scm, but does affect this plugin. The last email talks about 
this very same problem, however it's been almost 2 months with no response. Even 
for the past year none of the support questions have been answered.

---

Combined, this leads to a plugin that isn't usable at all and can mislead people 
into thinking that it works. Are their any plans to update it? Are their any 
plans to depreciate it? 


Thanks,
Leon



      
Mime
View raw message