maven-scm-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yair Friedman <Yair.Fried...@mtsint.com>
Subject VSS plugin to maven
Date Sun, 12 Jul 2009 13:54:07 GMT
Hi,

I have defined the VSS connection in Maven , and tried doing simple goals like mvn scm:update
.

I see in the Eclipse console (I use M2Eclipse) that the VSS command is executed properly ,
but nothing seems to happen .

It is apparently stuck I have waited for 10 minutes , with no result.

Here is the log :

[INFO] Scanning for projects...
[INFO] ------------------------------------------------------------------------
[INFO] Building testMaven
[INFO]
[INFO] Id: testMaven:testMaven:jar:0.0.1-SNAPSHOT
[INFO] task-segment: [scm:update] (aggregator-style)
[INFO] ------------------------------------------------------------------------
[INFO] [scm:update]
[INFO] Executing: "C:\Program Files\Microsoft Visual SourceSafe\ss" Get $/Projects/testMaven
-R -I- -GWS
[INFO] Working directory: D:\test_for_maven\testMaven


Here is my Configuration (pom.xml) :

<project xmlns="http://maven.apache.org/POM/4.0.0" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
  xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/maven-v4_0_0.xsd">
  <modelVersion>4.0.0</modelVersion>
  <groupId>testMaven</groupId>
  <artifactId>testMaven</artifactId>
  <packaging>jar</packaging>
  <version>0.0.1-SNAPSHOT</version>
  <name>testMaven</name>
  <url>http://maven.apache.org</url>
  <dependencies>
    <dependency>
      <groupId>junit</groupId>
      <artifactId>junit</artifactId>
      <version>3.8.1</version>
      <scope>test</scope>
    </dependency>
    <dependency>
      <groupId>org.apache.maven.scm</groupId>
     <artifactId>maven-scm-provider-vss</artifactId>
      <version>1.2</version>
    </dependency>

  </dependencies>

  <scm>
      <connection>scm:vss|\\mts-dev\vss\InvoiceManagement|/Projects/testMaven</connection>
  </scm>
  <build>
    <plugins>
      <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-scm-plugin</artifactId>
        <version>1.0</version>
        <configuration>
          <goals>install</goals>
        </configuration>
      </plugin>
    </plugins>
  </build>
</project>


I am stuck and really don't know how to figure this issue out
Please advise,


Regards,
Yair Friedman
MTS
Office: +972 (9) 7777 552
Email: yair.friedman@mtsint.com<BLOCKED::mailto:yair.friedman@mtsint.com>
Web : www.mtsint.com<BLOCKED::http://www.mtsint.com/>
MTS is a global provider of Operations Support Systems (OSS) solutions for comprehensive Telecommunication
Management and Customer Care & Billing (CC&B) used by Enterprises, Organizations,
and Service Providers.  Over 60,000 systems are deployed in 22 languages throughout the world!


Mime
View raw message