maven-scm-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mike Perham" <Mike.Per...@webifysolutions.com>
Subject RE: Question perforce
Date Mon, 22 May 2006 15:24:21 GMT
Why are you using backslashes in your connection URL?

________________________________

From: Okke Harsta [mailto:Okke.Harsta@tomtom.com] 
Sent: Monday, May 22, 2006 10:06 AM
To: scm-dev@maven.apache.org
Subject: Question perforce



Hi,

 

I'm trying to integrate continuum/maven2 with perforce. The following is
the setup:

 

bash-2.05$ p4 set

P4CLIENT=wis-censjava-commons-continuum

P4PORT=xxxx:1666

P4USER=wis

bash-2.05$ mvn scm:update
-DconnectionUrl=scm:perforce:\\depot-censjava\common

[INFO] Scanning for projects...

[INFO] Searching repository for plugin with prefix: 'scm'.

[INFO]
------------------------------------------------------------------------
-

---

[INFO] Building Cens Generic Components

[INFO]    task-segment: [scm:update] (aggregator-style)

[INFO]
------------------------------------------------------------------------
-

---

[INFO] [scm:update]

[INFO] Checkout working directory:
/export/home/continuum/p4/cens-commons

[INFO] Executing: p4 client -i

[ERROR] Provider message:

[ERROR] Unable to sync.  Are you logged in?

[ERROR] Command output:

[ERROR]

[INFO]
------------------------------------------------------------------------
-

---

[ERROR] BUILD ERROR

[INFO]
------------------------------------------------------------------------
-

---

[INFO] Command failed.Unable to sync.  Are you logged in?

[INFO]
------------------------------------------------------------------------
-

---

[INFO] For more information, run Maven with the -e switch

[INFO]
------------------------------------------------------------------------
-

---

[INFO] Total time: 16 seconds

[INFO] Finished at: Mon May 22 17:02:57 CEST 2006

[INFO] Final Memory: 4M/10M

[INFO]
------------------------------------------------------------------------
-

---

bash-2.05$

 

I know for sure the settings are correct, because this works fine:

 

bash-2.05$ p4 sync -n

File(s) up-to-date.

bash-2.05$

 

The login 'tip' in the error message is from the plugin and using -e -X
does not provide me the hint/hook I' m looking to. Any suggestions are
welcome.

 

Thnx,

Okke Harsta

 

________________________________

This e-mail message contains information which is confidential and may
be privileged. It is intended for use by the addressee only. If you are
not the intended addressee, we request that you notify the sender
immediately and delete or destroy this e-mail message and any
attachment(s), without copying, saving, forwarding, disclosing or using
its contents in any other way. TomTom N.V., TomTom International BV or
any other company belonging to the TomTom group of companies will not be
liable for damage relating to the communication by e-mail of data,
documents or any other information. 


Mime
View raw message