maven-notifications mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: maven-enforcer-m3.1.x #191
Date Fri, 27 Jan 2017 22:17:38 GMT
See <https://builds.apache.org/job/maven-enforcer-m3.1.x/191/>

------------------------------------------
[...truncated 846 lines...]
[INFO]   The build exited with code 1. See <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/maven-enforcer-plugin/target/it/ban-distribution-management-multi-module-except-site/build.log>
for details.
[INFO] Building: require-plugin-versions-expressions/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/maven-enforcer-plugin/target/it/require-plugin-versions-expressions/build.log>
for details.
[INFO] Building: require-active-profile-from-settings/pom.xml
[INFO] ..FAILED (0.3 s)
[INFO]   The build exited with code 1. See <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/maven-enforcer-plugin/target/it/require-active-profile-from-settings/build.log>
for details.
[INFO] Building: resolve_collect_dependencies/pom.xml
[INFO] ..FAILED (0.3 s)
[INFO]   The build exited with code 1. See <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/maven-enforcer-plugin/target/it/resolve_collect_dependencies/build.log>
for details.
[INFO] Building: require-upper-bound-deps_success/pom.xml
[INFO] ..FAILED (0.3 s)
[INFO]   The build exited with code 1. See <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/maven-enforcer-plugin/target/it/require-upper-bound-deps_success/build.log>
for details.
[INFO] Building: require-same-versions_failure/pom.xml
[INFO] ..SUCCESS (0.2 s)
[INFO] Building: banned-plugins/pom.xml
[INFO] ..FAILED (0.3 s)
[INFO]   The build exited with code 1. See <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/maven-enforcer-plugin/target/it/banned-plugins/build.log>
for details.
[INFO] Building: ban-distribution-management/pom.xml
[INFO] ..FAILED (0.3 s)
[INFO]   The build exited with code 1. See <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/maven-enforcer-plugin/target/it/ban-distribution-management/build.log>
for details.
[INFO] Building: multimodule/pom.xml
[INFO] ..FAILED (0.3 s)
[INFO]   The build exited with code 1. See <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/maven-enforcer-plugin/target/it/multimodule/build.log>
for details.
[INFO] Building: ban-transitive-dependencies-fail/pom.xml
[INFO] run script verify.groovy
[INFO] ..FAILED (0.3 s)
[INFO]   The post-build script did not succeed. assert buildLog.text.contains( '[WARNING]
Rule 0: org.apache.maven.plugins.enforcer.BanTransitiveDependencies failed with message:'
)
       |        |    |
       |        |    false
       |        Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/maven/cli/MavenCli
: Unsupported major.minor version 51.0
       |        	at java.lang.ClassLoader.defineClass1(Native Method)
       |        	at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
       |        	at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
       |        	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
       |        	at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
       |        	at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
       |        	at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
       |        	at java.security.AccessController.doPrivileged(Native Method)
       |        	at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
       |        	at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClassFromSelf(ClassRealm.java:401)
       |        	at org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass(SelfFirstStrategy.java:42)
       |        	at org.codehaus.plexus.classworlds.realm.ClassRealm.unsynchronizedLoadClass(ClassRealm.java:271)
       |        	at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:254)
       |        	at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:239)
       |        	at org.codehaus.plexus.classworlds.launcher.Launcher.getMainClass(Launcher.java:144)
       |        	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:266)
       |        	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
       |        	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
       |        	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
       |        Running post-build script: <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/maven-enforcer-plugin/target/it/ban-transitive-dependencies-fail/verify.groovy>
       <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/maven-enforcer-plugin/target/it/ban-transitive-dependencies-fail/build.log>
[INFO] Building: require-snapshot-version_success/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/maven-enforcer-plugin/target/it/require-snapshot-version_success/build.log>
for details.
[INFO] Building: dependencies_not_converging_test_scope/pom.xml
[INFO] ..SUCCESS (0.2 s)
[INFO] Building: banned-dependencies-versionrange/pom.xml
[INFO] ..FAILED (0.3 s)
[INFO]   The build exited with code 1. See <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/maven-enforcer-plugin/target/it/banned-dependencies-versionrange/build.log>
for details.
[INFO] Building: require-no-repositories_failure/pom.xml
[INFO] run script verify.groovy
[INFO] ..FAILED (0.3 s)
[INFO]   The post-build script did not succeed. assert buildLog.text.contains( '[WARNING]
Rule 0: org.apache.maven.plugins.enforcer.RequireNoRepositories failed with message:' )
       |        |    |
       |        |    false
       |        Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/maven/cli/MavenCli
: Unsupported major.minor version 51.0
       |        	at java.lang.ClassLoader.defineClass1(Native Method)
       |        	at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
       |        	at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
       |        	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
       |        	at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
       |        	at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
       |        	at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
       |        	at java.security.AccessController.doPrivileged(Native Method)
       |        	at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
       |        	at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClassFromSelf(ClassRealm.java:401)
       |        	at org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass(SelfFirstStrategy.java:42)
       |        	at org.codehaus.plexus.classworlds.realm.ClassRealm.unsynchronizedLoadClass(ClassRealm.java:271)
       |        	at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:254)
       |        	at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:239)
       |        	at org.codehaus.plexus.classworlds.launcher.Launcher.getMainClass(Launcher.java:144)
       |        	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:266)
       |        	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
       |        	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
       |        	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
       |        Running post-build script: <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/maven-enforcer-plugin/target/it/require-no-repositories_failure/verify.groovy>
       <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/maven-enforcer-plugin/target/it/require-no-repositories_failure/build.log>
[INFO] Building: require-release-dependencies-excludes_failure/pom.xml
[INFO] ..SUCCESS (0.2 s)
[INFO] Building: require-release-version/pom.xml
[INFO] ..FAILED (0.2 s)
[INFO]   The build exited with code 1. See <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/maven-enforcer-plugin/target/it/require-release-version/build.log>
for details.
[INFO] Building: ban-pom-dependency-version/pom.xml
[INFO] run script verify.groovy
[INFO] ..FAILED (0.3 s)
[INFO]   The post-build script did not succeed. assert buildLog.text.contains( '[WARNING]
Rule 0: org.apache.maven.plugins.enforcer.BanDuplicatePomDependencyVersions failed with message:'
)
       |        |    |
       |        |    false
       |        Exception in thread "main" java.lang.UnsupportedClassVersionError: org/apache/maven/cli/MavenCli
: Unsupported major.minor version 51.0
       |        	at java.lang.ClassLoader.defineClass1(Native Method)
       |        	at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631)
       |        	at java.lang.ClassLoader.defineClass(ClassLoader.java:615)
       |        	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141)
       |        	at java.net.URLClassLoader.defineClass(URLClassLoader.java:283)
       |        	at java.net.URLClassLoader.access$000(URLClassLoader.java:58)
       |        	at java.net.URLClassLoader$1.run(URLClassLoader.java:197)
       |        	at java.security.AccessController.doPrivileged(Native Method)
       |        	at java.net.URLClassLoader.findClass(URLClassLoader.java:190)
       |        	at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClassFromSelf(ClassRealm.java:401)
       |        	at org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy.loadClass(SelfFirstStrategy.java:42)
       |        	at org.codehaus.plexus.classworlds.realm.ClassRealm.unsynchronizedLoadClass(ClassRealm.java:271)
       |        	at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:254)
       |        	at org.codehaus.plexus.classworlds.realm.ClassRealm.loadClass(ClassRealm.java:239)
       |        	at org.codehaus.plexus.classworlds.launcher.Launcher.getMainClass(Launcher.java:144)
       |        	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:266)
       |        	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
       |        	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
       |        	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
       |        Running post-build script: <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/maven-enforcer-plugin/target/it/ban-pom-dependency-version/verify.groovy>
       <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/maven-enforcer-plugin/target/it/ban-pom-dependency-version/build.log>
[INFO] -------------------------------------------------
[INFO] Build Summary:
[INFO]   Passed: 6, Failed: 47, Errors: 0, Skipped: 0
[INFO] -------------------------------------------------
[ERROR] The following builds failed:
[ERROR] *  builds_a_pom_noop/pom.xml
[ERROR] *  require-active-profile-all/pom.xml
[ERROR] *  require-plugin-versions-projectGAVexpressions/pom.xml
[ERROR] *  require-upper-bound-deps_failure/pom.xml
[ERROR] *  require-java-version/pom.xml
[ERROR] *  require-same-versions_success/pom.xml
[ERROR] *  require-plugin-versions-plugin-with-integration-test-lifecycle/pom.xml
[ERROR] *  require-upper-bound-dependencies-unique_success/pom.xml
[ERROR] *  require-upper-bound-dependencies-unique_failure/pom.xml
[ERROR] *  banned-dependencies-wildcards/pom.xml
[ERROR] *  evaluate-beanshell/pom.xml
[ERROR] *  banned-dependencies-versionrange-fail/pom.xml
[ERROR] *  require-release-dependencies/pom.xml
[ERROR] *  require-no-repositories/pom.xml
[ERROR] *  ban-transitive-dependencies/pom.xml
[ERROR] *  banned-dependencies/pom.xml
[ERROR] *  require-release-dependencies-excludes/pom.xml
[ERROR] *  ban-distribution-management-multi-module-build/pom.xml
[ERROR] *  require-active-profile/pom.xml
[ERROR] *  require-files-size/pom.xml
[ERROR] *  require-plugin-versions/pom.xml
[ERROR] *  require-plugin-versions-custom-packaging/pom.xml
[ERROR] *  require-property/pom.xml
[ERROR] *  require-upper-bound-dependencies-managed_success/pom.xml
[ERROR] *  require-files-dont-exist/pom.xml
[ERROR] *  dependencies_converge/pom.xml
[ERROR] *  require-files-exist/pom.xml
[ERROR] *  require-maven-version/pom.xml
[ERROR] *  always-fail-warn/pom.xml
[ERROR] *  require-upper-bound-dependencies-managed_failure/pom.xml
[ERROR] *  require-file-checksum/pom.xml
[ERROR] *  always-pass/pom.xml
[ERROR] *  require-plugin-versions-plugin-with-extensions/pom.xml
[ERROR] *  ban-distribution-management-multi-module-except-site/pom.xml
[ERROR] *  require-plugin-versions-expressions/pom.xml
[ERROR] *  require-active-profile-from-settings/pom.xml
[ERROR] *  resolve_collect_dependencies/pom.xml
[ERROR] *  require-upper-bound-deps_success/pom.xml
[ERROR] *  banned-plugins/pom.xml
[ERROR] *  ban-distribution-management/pom.xml
[ERROR] *  multimodule/pom.xml
[ERROR] *  ban-transitive-dependencies-fail/pom.xml
[ERROR] *  require-snapshot-version_success/pom.xml
[ERROR] *  banned-dependencies-versionrange/pom.xml
[ERROR] *  require-no-repositories_failure/pom.xml
[ERROR] *  require-release-version/pom.xml
[ERROR] *  ban-pom-dependency-version/pom.xml
[INFO] -------------------------------------------------
[INFO] ------------------------------------------------------------------------
[INFO] Reactor Summary:
[INFO] 
[INFO] Apache Maven Enforcer .............................. SUCCESS [ 33.123 s]
[INFO] Apache Maven Enforcer API .......................... SUCCESS [ 13.357 s]
[INFO] Apache Maven Enforcer Rules ........................ SUCCESS [ 55.560 s]
[INFO] Apache Maven Enforcer Plugin ....................... FAILURE [ 30.571 s]
[INFO] ------------------------------------------------------------------------
[INFO] BUILD FAILURE
[INFO] ------------------------------------------------------------------------
[INFO] Total time: 02:28 min
[INFO] Finished at: 2017-01-27T22:17:24+00:00
[INFO] Final Memory: 50M/681M
[INFO] ------------------------------------------------------------------------
Waiting for Jenkins to finish collecting data
[ERROR] Failed to execute goal org.apache.maven.plugins:maven-invoker-plugin:2.0.0:run (integration-test)
on project maven-enforcer-plugin: 47 builds failed. See console output above for details.
-> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.maven.plugins:maven-invoker-plugin:2.0.0:run
(integration-test) on project maven-enforcer-plugin: 47 builds failed. See console output
above for details.
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:212)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116)
	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:80)
	at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:128)
	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307)
	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193)
	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106)
	at org.jvnet.hudson.maven3.launcher.Maven32Launcher.main(Maven32Launcher.java:132)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at org.codehaus.plexus.classworlds.launcher.Launcher.launchStandard(Launcher.java:330)
	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:238)
	at jenkins.maven3.agent.Maven32Main.launch(Maven32Main.java:186)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:57)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:606)
	at hudson.maven.Maven3Builder.call(Maven3Builder.java:136)
	at hudson.maven.Maven3Builder.call(Maven3Builder.java:71)
	at hudson.remoting.UserRequest.perform(UserRequest.java:153)
	at hudson.remoting.UserRequest.perform(UserRequest.java:50)
	at hudson.remoting.Request$2.run(Request.java:332)
	at hudson.remoting.InterceptingExecutorService$1.call(InterceptingExecutorService.java:68)
	at java.util.concurrent.FutureTask.run(FutureTask.java:262)
	at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1145)
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:615)
	at java.lang.Thread.run(Thread.java:745)
Caused by: org.apache.maven.plugin.MojoFailureException: 47 builds failed. See console output
above for details.
	at org.apache.maven.plugin.invoker.InvokerSession.handleFailures(InvokerSession.java:258)
	at org.apache.maven.plugin.invoker.InvokerMojo.processResults(InvokerMojo.java:69)
	at org.apache.maven.plugin.invoker.AbstractInvokerMojo.execute(AbstractInvokerMojo.java:741)
	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:207)
	... 31 more
[ERROR] 
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR] 
[ERROR] For more information about the errors and possible solutions, please read the following
articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException
[ERROR] 
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR]   mvn <goals> -rf :maven-enforcer-plugin
[JENKINS] Archiving <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/enforcer-api/pom.xml>
to org.apache.maven.enforcer/enforcer-api/1.4.2-SNAPSHOT/enforcer-api-1.4.2-SNAPSHOT.pom
[JENKINS] Archiving <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/enforcer-api/target/enforcer-api-1.4.2-SNAPSHOT.jar>
to org.apache.maven.enforcer/enforcer-api/1.4.2-SNAPSHOT/enforcer-api-1.4.2-SNAPSHOT.jar
[JENKINS] Archiving <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/maven-enforcer-plugin/pom.xml>
to org.apache.maven.plugins/maven-enforcer-plugin/1.4.2-SNAPSHOT/maven-enforcer-plugin-1.4.2-SNAPSHOT.pom
[JENKINS] Archiving <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/maven-enforcer-plugin/target/maven-enforcer-plugin-1.4.2-SNAPSHOT.jar>
to org.apache.maven.plugins/maven-enforcer-plugin/1.4.2-SNAPSHOT/maven-enforcer-plugin-1.4.2-SNAPSHOT.jar
[JENKINS] Archiving <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/enforcer-rules/pom.xml>
to org.apache.maven.enforcer/enforcer-rules/1.4.2-SNAPSHOT/enforcer-rules-1.4.2-SNAPSHOT.pom
[JENKINS] Archiving <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/enforcer-rules/target/enforcer-rules-1.4.2-SNAPSHOT.jar>
to org.apache.maven.enforcer/enforcer-rules/1.4.2-SNAPSHOT/enforcer-rules-1.4.2-SNAPSHOT.jar
[JENKINS] Archiving <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/enforcer-rules/target/enforcer-rules-1.4.2-SNAPSHOT-tests.jar>
to org.apache.maven.enforcer/enforcer-rules/1.4.2-SNAPSHOT/enforcer-rules-1.4.2-SNAPSHOT-tests.jar
[JENKINS] Archiving <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/pom.xml>
to org.apache.maven.enforcer/enforcer/1.4.2-SNAPSHOT/enforcer-1.4.2-SNAPSHOT.pom
[JENKINS] Archiving <https://builds.apache.org/job/maven-enforcer-m3.1.x/ws/target/enforcer-1.4.2-SNAPSHOT-site.xml>
to org.apache.maven.enforcer/enforcer/1.4.2-SNAPSHOT/enforcer-1.4.2-SNAPSHOT-site.xml
Sending e-mails to: notifications@maven.apache.org
channel stopped

Mime
View raw message