maven-m2-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John Casey (JIRA)" <>
Subject [jira] Work logged: (MNG-243) fails in IDEA plugin re-build with ClassNotFoundException
Date Mon, 04 Apr 2005 21:33:56 GMT
     [ ]

John Casey logged work on MNG-243:

           Time Worked: 3 hours
            Time Spent: 10800
    Remaining Estimate: 0


> fails in IDEA plugin re-build with ClassNotFoundException
> -----------------------------------------------------------------------------
>          Key: MNG-243
>          URL:
>      Project: m2
>         Type: Bug
>  Environment: local; not on CI
>     Reporter: John Casey
>      Fix For: 1.0-alpha-1

>   Time Spent: 3 hours
>    Remaining: 0 minutes
> For some reason, this is not happening on beaver. However, it's been reported at different
times by john (me), trygve, and apparently emmanuel (see dev list)...
> When running the bootstrap, mboot2 completes successfully.
> However, when the re-build of the maven-plugins directory is executed from the bootstrap
script, it fails during the IDEA plugin build, giving the following error:
> Exception in thread "main" java.lang.NoClassDefFoundError: org/apache/maven/plugin/resources/ResourceEntry
>         at org.apache.maven.plugin.resources.ResourcesMojo.getJarResources(
>         at org.apache.maven.plugin.resources.ResourcesMojo.execute(
>         at org.apache.maven.plugin.DefaultPluginManager.executeMojo(
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeMojo(
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executePhase(
>         at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(
>         at org.apache.maven.DefaultMaven.processProject(
>         at org.apache.maven.DefaultMaven.execute(
>         at org.apache.maven.cli.MavenCli.main(
>         at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>         at sun.reflect.NativeMethodAccessorImpl.invoke(
>         at sun.reflect.DelegatingMethodAccessorImpl.invoke(
>         at java.lang.reflect.Method.invoke(
>         at org.codehaus.classworlds.Launcher.launchEnhanced(
>         at org.codehaus.classworlds.Launcher.launch(
>         at org.codehaus.classworlds.Launcher.mainWithExitCode(
>         at org.codehaus.classworlds.Launcher.main(
> which kills the bootstrap process before the IT's run.
> Having said that, when the bootstrap dies I can manually cd into maven-plugins/ and execute
> 'm2 clean:clean install' (which is what command the bootstrap script fails on)
> and this will SUCCEED. If I then cd into ../maven-core-it/ and run
> './'
> this will successfully run the IT's. Yet for some reason, that re-build step fails in
the automated script...
> Another note is that I can disable the IDEA module in the maven-plugins pom.xml, and
the whole bootstrap script will complete normally.
> I've chased this error for about 3 hours now, and I still have no idea what could be
causing it. I suspect that if one of the "core" plugins had resources to copy, it would be
causing the failure instead of the IDEA plugin, but since they don't, I'd recommend moving
the IDEA plugin to some sort of "maven-nonessential-plugins" dir structure, and having a separate
pom with <modules/> to build this as a parallel structure to maven-plugins. We can then
add the Eclipse plugin to that new structure without muddying up the bootstrap process.
> The IDEA plugin doesn't need to be built by everyone with an itch to get at the m2 sources
anyway...they can still get it via the artifact repository.

This message is automatically generated by JIRA.
If you think it was sent incorrectly contact one of the administrators:
If you want more information on JIRA, or have a bug to report see:

View raw message