maven-m2-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Brett Porter <br...@apache.org>
Subject Re: Plugin parameters
Date Wed, 30 Mar 2005 13:13:35 GMT
I'm in favour of this - it was the intention of:

http://jira.codehaus.org/browse/MNG-221

If you'd like to add your examples to enhance that, that'd be great. I
guess we should do this for alpha-2 so the mojo specification can be
finalised. I'll schedule it.

Cheers,
Brett

Emmanuel Venisse wrote:

>Hi,
>
>Can we change the plugin parameter definition from class comment to field
>comment for obtain a more readable source?
>
>Actually, we have :
>/**
> ...
> * @parameter name="outputDirectory"
> * type="String"
> * required="true"
> * validator=""
> * expression="#project.build.outputDirectory"
> * description=""
> ...
> */
>
>Can we replace this by :
>
>/**
> * Description is here like a javadoc comment
> * @parameter
> * alias="optional name that replace the field name"
> * required="true"
> * validator=""
> * expression=="#project.build.outputDirectory"
> */
> String outputDirectory="aDefaultValue";
>
>=> the type isn't an attribute of parameter but the type of field
>
>I'm not sure if it's possible for inherited classes with inherited parameter
>field.
>
>Emmanuel
>
>
>  
>


Mime
View raw message