maven-m2-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Emmanuel Venisse" <emman...@venisse.net>
Subject Plugin parameters
Date Wed, 30 Mar 2005 13:07:09 GMT
Hi,

Can we change the plugin parameter definition from class comment to field
comment for obtain a more readable source?

Actually, we have :
/**
 ...
 * @parameter name="outputDirectory"
 * type="String"
 * required="true"
 * validator=""
 * expression="#project.build.outputDirectory"
 * description=""
 ...
 */

Can we replace this by :

/**
 * Description is here like a javadoc comment
 * @parameter
 * alias="optional name that replace the field name"
 * required="true"
 * validator=""
 * expression=="#project.build.outputDirectory"
 */
 String outputDirectory="aDefaultValue";

=> the type isn't an attribute of parameter but the type of field

I'm not sure if it's possible for inherited classes with inherited parameter
field.

Emmanuel


Mime
View raw message