maven-m2-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maczka Michal <michal.mac...@imtf.ch>
Subject RE: cvs commit: maven-components/maven-model maven.mdo
Date Thu, 03 Feb 2005 11:53:24 GMT
> ----------------------------------------------------------------------
>    
>   -    public List getSortedProjects( List projects ) throws Exception
>   +    public List getSortedProjects( List projects )
>   +    throws Exception


is this really preferred way of formatting?

IMO the first version is much more readable. I only move declaration of
exceptions to next line when 
method signature is long (I try not to exceed 80 characters in single line).

In such case I also indent the code differently


so in my case
public List getSortedProjects( List projects ) throws Exception


will become:
public List getSortedProjects( List projects ) 
            throws Exception


michal

Mime
View raw message