maven-m2-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maczka Michal <michal.mac...@imtf.ch>
Subject RE: documenting a minimum JDK
Date Wed, 22 Sep 2004 13:48:14 GMT


> -----Original Message-----
> From: Brett Porter [mailto:brett@apache.org]
> Sent: Wednesday, September 22, 2004 2:02 PM
> To: Maven 2 Developers List
> Subject: documenting a minimum JDK
> 
> 
> Currently, m2 only builds with JDK 1.4. Do we intend to 
> support JDK 1.3?
> 
> AFAIK, the missing pieces are:
> - sax parser for xstream (may soon become unnecessary, and 
> may be able 
> to use xpp3)
> - JCE/JSSE for Wagon (this is tricky... can be optional for SSH 
> installation)
> 

AFAIK we are very often using jdk 1.4 chained exceptions in plexus, m2 and
wagon

IMO it is resonable to require 1.4 these days for given tool.

if somebody will use JDK 1.3 or 1.2 for production envinronment it can still
use 1.4 to run maven and compile its code.
Probably we can require jre 1.4 and for example use eclipse compiler

If not we will have to change many lines of code for something which will be
much worst.


Michal

Mime
View raw message