maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] [maven-jlink-plugin] elharo commented on pull request #15: (no-issue) remove unused junit 4.
Date Fri, 13 Nov 2020 16:26:58 GMT

elharo commented on pull request #15:
URL: https://github.com/apache/maven-jlink-plugin/pull/15#issuecomment-726859821


   Strong no on this one. JUnit 4 is what the entire project uses. It's much better supported
by tooling. JUnit 5 seems to be a completely new thing that has not achieved broad adoption.
For example, I just noticed Eclipse doesn't support this. We should stick to JUnit 4 for now,
and any choice to upgrade should be discussed across the community, not just within one PR
in one repo. 


----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.

For queries about this service, please contact Infrastructure at:
users@infra.apache.org



Mime
View raw message