maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Scholte (Jira)" <j...@apache.org>
Subject [jira] [Updated] (MENFORCER-277) Upgrade maven-dependency-tree to 3.x
Date Thu, 30 Jul 2020 20:31:00 GMT

     [ https://issues.apache.org/jira/browse/MENFORCER-277?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Scholte updated MENFORCER-277:
-------------------------------------
    Fix Version/s: 3.0.0

> Upgrade maven-dependency-tree to 3.x
> ------------------------------------
>
>                 Key: MENFORCER-277
>                 URL: https://issues.apache.org/jira/browse/MENFORCER-277
>             Project: Maven Enforcer Plugin
>          Issue Type: Improvement
>    Affects Versions: 1.4.1
>            Reporter: Robert Scholte
>            Priority: Major
>             Fix For: 3.0.0
>
>         Attachments: MENFORCER-277.patch
>
>
> As part of MENFORCER-264 maven-dependency-tree should be upgraded. This would imply switching
from the M2 {{DependencyTreeBuilder}} to M2/M3 {{DependencyGraphBuilder}}.
> However, {{DependencyGraphBuilder}} uses {{ProjectDependenciesResolver}}, which provides
the *resolved* graph instead of a raw tree.
> This is a requirement for both {{DependencyConvergence}} and {{RequireUpperBoundDeps}}.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message