maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hudson (Jira)" <j...@apache.org>
Subject [jira] [Commented] (MNG-6081) Log refactoring - Method Invocation Replaced By Variable
Date Sat, 28 Mar 2020 15:00:03 GMT

    [ https://issues.apache.org/jira/browse/MNG-6081?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17069637#comment-17069637
] 

Hudson commented on MNG-6081:
-----------------------------

Build failed in Jenkins: Maven TLP » maven-studies » maven-metrics #4

See https://builds.apache.org/job/maven-box/job/maven-studies/job/maven-metrics/4/

> Log refactoring - Method Invocation Replaced By Variable
> --------------------------------------------------------
>
>                 Key: MNG-6081
>                 URL: https://issues.apache.org/jira/browse/MNG-6081
>             Project: Maven
>          Issue Type: Improvement
>          Components: core
>    Affects Versions: 3.3.9
>            Reporter: Nemo Chen
>            Assignee: Michael Osipov
>            Priority: Minor
>             Fix For: 3.5.0-alpha-1, 3.5.0
>
>         Attachments: MNG-6081.patch
>
>
> *Method Invocation Replaced By Variable*
> In file: apache-maven-3.3.9/maven-compat/src/main/java/org/apache/maven/artifact/resolver/DebugResolutionListener.java
> from line 70:
> {code}
> String keptVersion = kept.getVersion();
> if ( omittedVersion != null ? !omittedVersion.equals( keptVersion ) : keptVersion !=
null )
> {
>     logger.debug( indent + omitted + " (removed - nearer found: " + kept.getVersion()
+ ")" );
> }
> {code}
> the "kept.getVersion()" can be replaced with "keptVersion" for the sake of simplicity
and readability.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message