maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chris Lott (Jira)" <j...@apache.org>
Subject [jira] [Comment Edited] (MJAVADOC-617) aggregate-jar does nothing if aggregator modules are referenced using relative pathes and are not in sub folders (
Date Thu, 16 Jan 2020 11:33:00 GMT

    [ https://issues.apache.org/jira/browse/MJAVADOC-617?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17016819#comment-17016819
] 

Chris Lott edited comment on MJAVADOC-617 at 1/16/20 11:32 AM:
---------------------------------------------------------------

Please tell me if this symptom is caused by the same problem. I have a simple multi-module
project with parent and a single child. Working in the parent, I invoke the javadoc:aggregate
version 3.1.1 feature like this
{noformat}
    mvn -f . javadoc:aggregate{noformat}
I know this usage is a little silly, maven defaults to the current directory so there's no
need for the -f option.  But it appears harmless.

Anyhhow, when invoked like this the full maven build runs and javadoc is generated in the
child module. But in the last step, where I expect the aggregation to happen, the plugin shows
that it has been invoked:
{noformat}
    maven-javadoc-plugin:3.1.1:aggregate{noformat}
But it shows no other output, does not print an error or warning, and it does not copy the
child module's javadoc files into parent/target/site/apidocs/

Thanks in advance!


was (Author: chrislott):
Please tell me if this symptom is caused by the same problem. I have a simple multi-module
project with parent and a single child. Working in the parent, I invoke the javadoc:aggregate
version 3.1.1 feature like this
{noformat}
    mvn -f . javadoc:aggregate{noformat}
The full build runs and javadoc is generated in the child module. But in the last step, where
I expect the aggregation to happen, the plugin shows that it has been invoked:
{noformat}
    maven-javadoc-plugin:3.1.1:aggregate{noformat}
But it shows no other output, does not print an error or warning, and it does not copy the
child module's javadoc files into parent/target/site/apidocs/

Thanks in advance!

> aggregate-jar does nothing if aggregator modules are referenced using relative pathes
and are not in sub folders (
> ------------------------------------------------------------------------------------------------------------------
>
>                 Key: MJAVADOC-617
>                 URL: https://issues.apache.org/jira/browse/MJAVADOC-617
>             Project: Maven Javadoc Plugin
>          Issue Type: Bug
>    Affects Versions: 3.1.0, 3.1.1
>            Reporter: Reto Weiss
>            Priority: Major
>         Attachments: fix.zip
>
>          Time Spent: 10m
>  Remaining Estimate: 0h
>
> If an aggregator project has modules that are not located in sub folders and are referenced
using relative pathes (e.g. "../project1") then the javadoc aggregate-jar does nothing.
> It does not fail but no javadoc is generated at all.
> This works with 3.0.1.
> See attached Zip File with three projects all, project1 and project2. Project all is
the aggregator project. It references project 1 and project 2 with ../project1 and ../project2



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message