maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Osipov (Jira)" <j...@apache.org>
Subject [jira] [Commented] (MCOMPILER-404) Update default source/target from 1.6 to 1.7
Date Mon, 02 Dec 2019 08:02:00 GMT

    [ https://issues.apache.org/jira/browse/MCOMPILER-404?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16985884#comment-16985884
] 

Michael Osipov commented on MCOMPILER-404:
------------------------------------------

You can always use Java 11, I consider

bq. Otherwise compiling sources with Maven on Java 12+ will lead to errors in case no explicit
source/target/release is set.

to be a weak argument because this problem will reoccur with every new major release.

> Update default source/target from 1.6 to 1.7
> --------------------------------------------
>
>                 Key: MCOMPILER-404
>                 URL: https://issues.apache.org/jira/browse/MCOMPILER-404
>             Project: Maven Compiler Plugin
>          Issue Type: Improvement
>    Affects Versions: 3.8.1
>            Reporter: Konrad Windszus
>            Priority: Major
>
> Similar to what was done in MCOMPILER-335 the default should now be 1.7, as that is the
oldest version being supported by javac in Java 12 and Java 13 (https://docs.oracle.com/en/java/javase/12/tools/javac.html#GUID-AEEC9F07-CB49-4E96-8BC7-BCC2C7F725C9__GUID-D343F6B4-3FDD-43A8-AD24-43DD70214471).
> Otherwise compiling sources with Maven on Java 12+ will lead to errors in case no explicit
source/target/release is set.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message