maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Elliotte Rusty Harold (Jira)" <j...@apache.org>
Subject [jira] [Commented] (MENFORCER-251) Enhance requireReleaseDeps rule to allow SNAPSHOTS that have not been released
Date Mon, 16 Dec 2019 12:15:00 GMT

    [ https://issues.apache.org/jira/browse/MENFORCER-251?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16997222#comment-16997222
] 

Elliotte Rusty Harold commented on MENFORCER-251:
-------------------------------------------------

This seems counter to the goal of the rule. I'm inclined to close it. 

> Enhance requireReleaseDeps rule to allow SNAPSHOTS that have not been released
> ------------------------------------------------------------------------------
>
>                 Key: MENFORCER-251
>                 URL: https://issues.apache.org/jira/browse/MENFORCER-251
>             Project: Maven Enforcer Plugin
>          Issue Type: New Feature
>          Components: Standard Rules
>    Affects Versions: 1.4.1
>            Reporter: Jason W. Thompson
>            Priority: Major
>
> When managing dependencies that are used by many projects, it is sometimes helpful to
know when a SNAPSHOT dependency is released. I would like to fail a build which depends on
a dependency such as 1.3-SNAPSHOT when there exists a 1.3. However, I do not want to fail
if 1.3 has not been released.
> Essentially, it would be helpful to have something to behave similar to [versions:use-releases|http://www.mojohaus.org/versions-maven-plugin/use-releases-mojo.html]
except instead of modifying the pom, it would fail the build.



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message