maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Scholte (Jira)" <j...@apache.org>
Subject [jira] [Commented] (MSITE-757) drop Maven 2 support
Date Tue, 17 Dec 2019 21:22:00 GMT

    [ https://issues.apache.org/jira/browse/MSITE-757?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16998596#comment-16998596
] 

Robert Scholte commented on MSITE-757:
--------------------------------------

Maven Site Plugin is one of the few plugins that got the 3.x version before we decided that
3.x meant "requires Maven 3". 
To really drop Maven 2, the following needs to be done: https://cwiki.apache.org/confluence/display/MAVEN/Plugin+migration+to+Maven3+dependencies

> drop Maven 2 support
> --------------------
>
>                 Key: MSITE-757
>                 URL: https://issues.apache.org/jira/browse/MSITE-757
>             Project: Maven Site Plugin
>          Issue Type: Task
>    Affects Versions: 3.4
>            Reporter: Herve Boutemy
>            Priority: Major
>
> this will permit some code cleanup, since there are some hacks to make reporting work
on both Maven 2 and Maven 3 (which has changed much)



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message