maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Markus Bader (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MNG-6710) Stackoverflow while compiling Java Sources, but works after renaming project directory
Date Wed, 17 Jul 2019 06:23:00 GMT

    [ https://issues.apache.org/jira/browse/MNG-6710?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16886712#comment-16886712
] 

Markus Bader commented on MNG-6710:
-----------------------------------

We tried 1.8.0_172, 1.8.0_211 and 1.8.0_221: All the same result.

Unfortunately our sources are not compatible to Java 11, so I couldn't try 11.

> Stackoverflow while compiling Java Sources, but works after renaming project directory
> --------------------------------------------------------------------------------------
>
>                 Key: MNG-6710
>                 URL: https://issues.apache.org/jira/browse/MNG-6710
>             Project: Maven
>          Issue Type: Bug
>    Affects Versions: 3.6.1
>         Environment: The problem occurs with Windows 10 and also with Windows 7.
>            Reporter: Markus Bader
>            Priority: Major
>         Attachments: build.log
>
>
> Me and one of my colleagues have following problem (others do not): We want to build
a maven project, but "mvn clean install" ends up in a stackoverflow error. But after renaming
the project directory, it works. Also after renaming the name of the parent directory and
leaving the name of the project directory by its original value, compilation is possible.
>  I also tried changing the artifactId so that it doesn't match the folder name. Result:
stackoverflow.
> To make it more strange: I tried to reduce the used Java classes for possibly identifying
a class to be responsible for this phenomenon. Therefor I deleted a class named "MathParser"
and after that compilation was possible. So I analysed the content of the class and found
out, that the stackoverflow error occurs even if the class ist nearly empty. With following
content I can reproduce the error:
>  
> {code:java}
> package some.anonymised.package;
> public class MathParser {
>     private void doSomething(String func) throws Exception {
>         throw new Exception ("function '" + func + "' is not defined");
>     }
> } {code}
> With an empty method body, the build works fine.
> I attached the log created with debug option activated (with reduced number of classes
and reduced content of MathParser). For anonymisation purposes I replaced the name of some
directories, packages etc. by "xxxxx".



--
This message was sent by Atlassian JIRA
(v7.6.14#76016)

Mime
View raw message