maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Michael Osipov (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MNG-6678) locked version range to a timestamped snapshot does not work
Date Fri, 14 Jun 2019 06:10:00 GMT

     [ https://issues.apache.org/jira/browse/MNG-6678?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Michael Osipov updated MNG-6678:
--------------------------------
    Fix Version/s: waiting-for-feedback

> locked version range to a timestamped snapshot does not work
> ------------------------------------------------------------
>
>                 Key: MNG-6678
>                 URL: https://issues.apache.org/jira/browse/MNG-6678
>             Project: Maven
>          Issue Type: Bug
>          Components: Artifacts and Repositories
>    Affects Versions: 3.6.0
>            Reporter: James Nord
>            Priority: Major
>             Fix For: waiting-for-feedback
>
>
> I had built and deployed a snapshot to our internal repo mananger (nexus) and then attempted
to force the use of that artifact in a downstream project by using an explicit version range
for that artifact.
> However when I tried to do this maven complained the version range could not be satisfied.
> for example the snapshot deployed with timestamp {{2.176.1.3-20190613.140544-1}} and
the range I tried to use was {{[2.176.1.3-20190613.140544-1]}} 
> in the {{maven-metadata.xml}} from the artifact root in the repo I see 2.176.1.3-SNAPSHOT
is mentioned, and looking in the {{maven-metadata.xml}} for the 2.176.1.3-SNAPSHOT I do see
it contains that in the list of {{snapshotVersions}}
> This appears to be to be a bug that the versionRange does not correctly identify a timestamped
version as a SNAPSHOT and thus resolve the metadata for the snapshot correctly to see what
versions of that SNAPSHOT are available.
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message