maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From GitBox <...@apache.org>
Subject [GitHub] [maven-enforcer] belingueres commented on a change in pull request #38: [MENFORCER-313] - Added [<scope>] to the conflicting artifacts in the output. Highlight those with compile scope.
Date Tue, 25 Jun 2019 16:08:41 GMT
belingueres commented on a change in pull request #38: [MENFORCER-313] - Added [<scope>]
to the conflicting artifacts in the output. Highlight those with compile scope.
URL: https://github.com/apache/maven-enforcer/pull/38#discussion_r297271210
 
 

 ##########
 File path: enforcer-rules/src/main/java/org/apache/maven/plugins/enforcer/RequireUpperBoundDeps.java
 ##########
 @@ -236,7 +237,17 @@ private String getFullArtifactName( DependencyNode node, boolean usePremanaged
)
         {
             version = uniqueVersions ? artifact.getVersion() : artifact.getBaseVersion();
         }
-        return artifact.getGroupId() + ":" + artifact.getArtifactId() + ":" + version;
+        String result = artifact.getGroupId() + ":" + artifact.getArtifactId() + ":" + version;
+        if ( artifact.getScope() != null )
 
 Review comment:
   ![requireUpper](https://user-images.githubusercontent.com/1631042/60114012-52426300-9749-11e9-80b2-afa14990f0e8.png)
   
   Eclipse show in black font the compile dependencies and in grey color other scopes (test,
runtime). I added the font highlight to the compile dependencies to resemble this, but I'm
open to suggestions.

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on to GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


With regards,
Apache Git Services

Mime
View raw message