maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anders Hammar (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MJAR-266) "unknown error" in Eclipse when upgrading m-jar-p to 3.1.2
Date Fri, 24 May 2019 09:54:00 GMT

    [ https://issues.apache.org/jira/browse/MJAR-266?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16847420#comment-16847420
] 

Anders Hammar commented on MJAR-266:
------------------------------------

This issue should probably also be filed towards the Eclipse m2e project.

> "unknown error" in Eclipse when upgrading m-jar-p to 3.1.2
> ----------------------------------------------------------
>
>                 Key: MJAR-266
>                 URL: https://issues.apache.org/jira/browse/MJAR-266
>             Project: Maven JAR Plugin
>          Issue Type: Bug
>    Affects Versions: 3.1.2
>         Environment: * Eclipse IDE for Enterprise Java Developers
>   Version: 2019-06 M2 (4.12.0M2)
>   Build id: 20190509-1623
> * m2e 1.12.0.20190517-1754
> $ java -version
> openjdk version "11.0.3" 2019-04-16
> OpenJDK Runtime Environment AdoptOpenJDK (build 11.0.3+7)
> Eclipse OpenJ9 VM AdoptOpenJDK (build openj9-0.14.0, JRE 11 Windows 8.1 amd64-64-Bit
Compressed References 20190417_198 (JIT enabled, AOT enabled)
> OpenJ9   - bad1d4d06
> OMR      - 4a4278e6
> JCL      - 5cc996a803 based on jdk-11.0.3+7)
>            Reporter: Thorsten Heit
>            Priority: Major
>
> I have a parent pom that defines the plugin versions to use in dependend projects. So
far I had the following snippet in it:
> {code:xml}
> <plugin>
>     <groupId>org.apache.maven.plugins</groupId>
>     <artifactId>maven-jar-plugin</artifactId>
>     <version>3.1.1</version>
> </plugin>
> {code}
> When I change the version to 3.1.2, Eclipse marks all my projects that inherit from that
pom as erroneous. In the problems view I see
> ||Description||Resource||Path||Location||Type||
> |Errors:
> * Unknown|pom.xml|/myproject|line 1|Maven Configuration Problem|
> Building the projects from the command line works, and downgrading to 3.1.1 lets the
errors disappear.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message