maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Dangel (JIRA)" <j...@apache.org>
Subject [jira] [Closed] (MPMD-280) maven-pmd-plugin does not support targetJdk 12
Date Wed, 03 Apr 2019 17:44:03 GMT

     [ https://issues.apache.org/jira/browse/MPMD-280?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andreas Dangel closed MPMD-280.
-------------------------------

> maven-pmd-plugin does not support targetJdk 12
> ----------------------------------------------
>
>                 Key: MPMD-280
>                 URL: https://issues.apache.org/jira/browse/MPMD-280
>             Project: Maven PMD Plugin
>          Issue Type: New Feature
>          Components: PMD
>    Affects Versions: 3.11.0
>         Environment: openjdk version "12" 2019-03-19
> OpenJDK Runtime Environment 19.3 (build 12+33)
> OpenJDK 64-Bit Server VM 19.3 (build 12+33, mixed mode, sharing)
> Fedora release 29 (Twenty Nine)
>            Reporter: Steven Schlansker
>            Assignee: Andreas Dangel
>            Priority: Major
>             Fix For: 3.12.0
>
>
> Attempting to use maven-pmd-plugin with the newly GA openjdk12 and source/target level
12 results in:
>  
> {code:java}
> Caused by: org.apache.maven.reporting.MavenReportException: Unsupported targetJdk value
'12'.
> at org.apache.maven.plugins.pmd.PmdReport.getPMDConfiguration (PmdReport.java:672)
> at org.apache.maven.plugins.pmd.PmdReport.executePmd (PmdReport.java:390)
> at org.apache.maven.plugins.pmd.PmdReport.executePmdWithClassloader (PmdReport.java:355)
> at org.apache.maven.plugins.pmd.PmdReport.canGenerateReport (PmdReport.java:329)
> at org.apache.maven.reporting.AbstractMavenReport.execute (AbstractMavenReport.java:120{code}
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message