maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karl Heinz Marbaise (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MASSEMBLY-907) Dependencies are not included when run with mvn install
Date Wed, 27 Mar 2019 09:28:00 GMT

    [ https://issues.apache.org/jira/browse/MASSEMBLY-907?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16802591#comment-16802591
] 

Karl Heinz Marbaise commented on MASSEMBLY-907:
-----------------------------------------------

Can you please add the logging output of the two executions you have mentioned...

> Dependencies are not included when run with mvn install
> -------------------------------------------------------
>
>                 Key: MASSEMBLY-907
>                 URL: https://issues.apache.org/jira/browse/MASSEMBLY-907
>             Project: Maven Assembly Plugin
>          Issue Type: Bug
>    Affects Versions: 3.1.1
>            Reporter: Lau Bakman
>            Assignee: Karl Heinz Marbaise
>            Priority: Major
>         Attachments: assembly_deps.zip
>
>
> We have just updated to version 3.1.1 due to MASSEMBLY-873 and have stumbled upon a problem.
> Our project is structured similar to the attached project. When we build our project
using "mvn clean package" the project is assembled correctly including dependencies. If we
on the other hand build our project using "mvn clean install", only the top level jar files
are assembled and all dependencies are missing.
> This worked in version 3.1.0.
> Is this by design? And if it is, is there a way to revert to the old behavior?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message