maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Christian Stein (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (SUREFIRE-1585) Align JUnit Platform version at runtime
Date Mon, 03 Dec 2018 12:50:00 GMT

    [ https://issues.apache.org/jira/browse/SUREFIRE-1585?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16707150#comment-16707150
] 

Christian Stein commented on SUREFIRE-1585:
-------------------------------------------

Reduced the scope of this issue to *aligning JUnit Platform version at runtime*.

The auto-resolve feature described here is not future-proof and will be superseded by the
"junit-jupiter" aggregator artifact in JUnit Jupiter 5.4.0-M1

https://github.com/junit-team/junit5/commit/88b1492d524c4a96bb000f2c46f7b05552d7aea6

> Align JUnit Platform version at runtime
> ---------------------------------------
>
>                 Key: SUREFIRE-1585
>                 URL: https://issues.apache.org/jira/browse/SUREFIRE-1585
>             Project: Maven Surefire
>          Issue Type: Improvement
>          Components: JUnit 5.x support
>    Affects Versions: 2.22.1
>            Reporter: Christian Stein
>            Assignee: Christian Stein
>            Priority: Minor
>              Labels: features
>             Fix For: Backlog
>
>
> Providers should be able to enhance the test runtime by injecting "missing" artifacts
before executing tests.
>  
> For example, the JUnit Platform Provider should add "missing" Test Engine artifacts for
when users only depend on the API of a test framework.
>  * User test depends on *`junit-jupiter-api`* only? Provide *`junit-jupiter-engine`*
at test runtime -- automatically or via plugin deps.
>  * User test depends on *`junit-jupiter-params`* only? That pulls in *`junit-jupiter-api`*
transitively. Provide *`junit-jupiter-engine`* at test runtime -- automatically or via plugin
deps.
>  * User test depends on *`junit:junit:4.12`* only *AND* the JUnit Platform Provider is
forced? Provide *`junit-vintage-engine`* at test runtime -- automatically or via plugin deps.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message