maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benjamin Cartereau (JIRA)" <>
Subject [jira] [Created] (MEAR-272) SNAPSHOT dependencies are copied with timestamp
Date Thu, 08 Nov 2018 15:58:00 GMT
Benjamin Cartereau created MEAR-272:

             Summary: SNAPSHOT dependencies are copied with timestamp
                 Key: MEAR-272
             Project: Maven Ear Plugin
          Issue Type: Bug
    Affects Versions: 3.0.1
         Environment: JDK 8
Maven 3.3 and 3.5
            Reporter: Benjamin Cartereau

We have an EAR project that have a dependency towards a SNAPSHOT (version in dependency within
the pom set as "1.0-SNASPHOT") version of a jar stored in our Nexus repository.

When we build the project, the ear:ear plugin is executed and we can see that the timestamp
version of the dependency is copied as is:

[INFO] Copying artifact[jar:xxx:yyy:1.0-20181106.150409-27] to[yyy-*1.0-20181106.150409-27*.jar]

We also tried with the 3.0.0 version of the ear plugin and we get the same result.

Then we have tried the 2.10.1 version of the plugin (with the useBaseVersion set to true in
ear plugin configuration) and it is now working:

[INFO] Copying artifact[jar:xxx:yyy:1.0-20181106.150409-27] to[yyy-*1.0-SNAPSHOT*.jar]

The "useBaseVersion" parameter has no effect with 3.0.1 version of the plugin except displaying
the warn message "Using _useBaseVersion_ not _yet_ fixed".

This message was sent by Atlassian JIRA

View raw message