maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sylwester Lachiewicz (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (MSITE-758) upgrade wagon-api from 1.0 to 2.x
Date Wed, 14 Nov 2018 16:24:00 GMT

    [ https://issues.apache.org/jira/browse/MSITE-758?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16686811#comment-16686811
] 

Sylwester Lachiewicz edited comment on MSITE-758 at 11/14/18 4:23 PM:
----------------------------------------------------------------------

\+1 to support only 3.0.5+


was (Author: slachiewicz):
+1 to support only 3.0.5+

> upgrade wagon-api from 1.0 to 2.x
> ---------------------------------
>
>                 Key: MSITE-758
>                 URL: https://issues.apache.org/jira/browse/MSITE-758
>             Project: Maven Site Plugin
>          Issue Type: Task
>          Components: site:deploy
>    Affects Versions: 3.4
>            Reporter: Hervé Boutemy
>            Priority: Major
>
> I don't really know what changed from wagon-api 1.0 to 2.0
> or from 2.0 to 2.10 (= latest when writing this)
> but this is just about the general idea of dropping old wagon 1.0 dependency to get a
newer one
> for reference:
> - Maven 2..x to 3.0.3 use wagon 1.0-beta http://maven.apache.org/ref/3.0.3/apache-maven/dependencies.html
> - Maven 3.0.4 uses wagon 2.2 http://maven.apache.org/ref/3.0.4/apache-maven/dependencies.html
> - Maven 3.0.5 uses wagon 2.4 http://maven.apache.org/ref/3.0.5/apache-maven/dependencies.html
> ...



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message