maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MPMD-270) JDK 11 compatibility
Date Wed, 03 Oct 2018 05:35:00 GMT

    [ https://issues.apache.org/jira/browse/MPMD-270?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16636482#comment-16636482
] 

ASF GitHub Bot commented on MPMD-270:
-------------------------------------

olamy opened a new pull request #4: MPMD-270 add jdk11 it test
URL: https://github.com/apache/maven-pmd-plugin/pull/4
 
 
   

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


> JDK 11 compatibility
> --------------------
>
>                 Key: MPMD-270
>                 URL: https://issues.apache.org/jira/browse/MPMD-270
>             Project: Maven PMD Plugin
>          Issue Type: Bug
>          Components: PMD
>    Affects Versions: 3.10.0
>            Reporter: Simone Bordet
>            Assignee: Olivier Lamy (*$^¨%`£)
>            Priority: Major
>
> Apparently, the Maven PMD plugin does not work with JDK 11.
> Error message:
> {{[ERROR] Failed to execute goal org.apache.maven.plugins:maven-pmd-plugin:3.10.0:pmd
(pmd) on project jetty-util: Execution pmd of goal org.apache.maven.plugins:maven-pmd-plugin:3.10.0:pmd
failed: org.apache.maven.reporting.MavenReportException: Unsupported targetJdk value '11'.
-> [Help 1]}}
> See also: https://github.com/eclipse/jetty.project/issues/2948
> Thanks!



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message