maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Lillie (JIRA)" <>
Subject [jira] [Commented] (MDEPLOY-244) maven deploy plugin 3.0.0-M1 breaks RPM deploys
Date Fri, 12 Oct 2018 18:01:00 GMT


Andrew Lillie commented on MDEPLOY-244:

[~khmarbaise] I knew what you meant the first time ;)

In any case, I just tried that, and indeed that resolves the issue.

> maven deploy plugin 3.0.0-M1 breaks RPM deploys
> -----------------------------------------------
>                 Key: MDEPLOY-244
>                 URL:
>             Project: Maven Deploy Plugin
>          Issue Type: Bug
>          Components: deploy:deploy-file
>    Affects Versions: 3.0.0-M1
>            Reporter: William So
>            Priority: Critical
>         Attachments: project-pom.xml, root-pom.xml,
> After upgrading to maven deploy plugin to 3.0.0-M1, our Maven Builds that uploads an
RPM artifact broke.  All other artifacts, like zips, pom, jar, etc.. was able to upload without
problems.    But as soon as the build tried to upload an RPM the upload threw an 401 Error:  
> [Continue Pipeline] [ERROR] Failed to execute goal org.apache.maven.plugins:maven-deploy-plugin:3.0.0-M1:deploy
(default-deploy) on project company-fancyname-atg-apptype-ibm-qa4: ArtifactDeployerException:
Failed to deploy artifacts: Could not transfer artifact com.sephops.fancyname:company-fancyname-atg-apptype-ibm-qa4:rpm:ProjectName-20181001.061415-35
from/to company-snapshot-yum::default (
Failed to transfer file:
Return code is: 401, ReasonPhrase: Unauthorized. -> [Help 1]

This message was sent by Atlassian JIRA

View raw message