maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arjan Tijms (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (MNG-6399) Lift JDK minimum to JDK 8
Date Tue, 23 Oct 2018 23:04:00 GMT

    [ https://issues.apache.org/jira/browse/MNG-6399?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16661436#comment-16661436
] 

Arjan Tijms edited comment on MNG-6399 at 10/23/18 11:03 PM:
-------------------------------------------------------------

I also think it would be a good idea to say something about baseline version updated in some
formal way.

Before long we'll be on Java 24, and if Maven would still be restricted to Java 7 it would
feel completely antiquated, which on its turn would hinder new developers coming into the
project.

Just think of you wanting to contribute to a project today. You clone its source, ready to
inspect it and find out where to start. Then horrors of horrors, it appears to be Java 1.0!

Not even the collection framework would be there, everything being Vector and Hashtable,
and that all because the maintainer 15 years ago saw zero benefit in updating tot Java 1.1.

 

 


was (Author: arjan.tijms):
I also think it would be a good idea to say something about baseline version updated in some
formal way.

Before long we'll be on Java 24, and if Maven would still be restricted to Java 7 it would
feel completely antiquated, which on its turn would hinder new developers coming into the
project.

Just think of you wanting to contribute to a project today. You clone its source, ready to
inspect it and find out where to start. Then horrors of horrors, it appears to be Java 1.0!

Not even the collection framework would be there, everyone being Vector and Hashtable, and
that all because the maintainer 15 years ago saw zero benefit in updating tot Java 1.1.

 

 

> Lift JDK minimum to JDK 8
> -------------------------
>
>                 Key: MNG-6399
>                 URL: https://issues.apache.org/jira/browse/MNG-6399
>             Project: Maven
>          Issue Type: Task
>    Affects Versions: 3.6.0
>            Reporter: Karl Heinz Marbaise
>            Priority: Critical
>             Fix For: 3.6.x-candidate
>
>
> I would like to lift the minimum of Maven Core to JDK 8 (I think it's time)..



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message