maven-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Scholte (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MCOMPILER-322) Set the JPMS module version
Date Tue, 07 Aug 2018 19:58:00 GMT

     [ https://issues.apache.org/jira/browse/MCOMPILER-322?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Robert Scholte updated MCOMPILER-322:
-------------------------------------
    Summary: Set the JPMS module version  (was: Add parameter to set the JPMS module version)

> Set the JPMS module version
> ---------------------------
>
>                 Key: MCOMPILER-322
>                 URL: https://issues.apache.org/jira/browse/MCOMPILER-322
>             Project: Maven Compiler Plugin
>          Issue Type: Improvement
>            Reporter: Plamen Totev
>            Priority: Minor
>
> The {{javac}} compiler (Java 9+) allows you to set the Java module version. It would
be nice if the compiler plugin allows the user to set this value. The default value should
be the project version.
> While it is true that the module version is not really used by JPMS, it would be nice
if the modules created by Maven does have the version set. It could be useful for debugging
for example.
>  
> I'm not sure if we need the version only for the {{compile}} target or it useful for
{{testCompile}} as well?



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message